Ctrl+A Ctrl+C (Cmd+A Cmd+C) does not copy text in preview

Steps to reproduce

Create a note. Go into Preview Mode. Press Ctrl A. Press Ctrl C. Try to paste text using Ctrl V.

Expected result

To paste the copied text.

Actual result

The copied text is not pasted.

Environment

  • Operating system: macOS Big Sur 11.1 & Windows 10
  • Obsidian version: 0.13.2

3 Likes

I don’t have this problem here.
I can copy the text and paste it into any other program.

Steps to reproduce
Create a note. Go into Preview Mode. Select all (Cmd + A) or Edit -> Select All . Press Cmd C. Try to paste text using Cmd V.

Expected result
To paste the copied text.

Actual result
The copied text is not pasted or the text is not copied at all

Environment
Operating system: macOS Big Sur 11.1
Obsidian version: 0.10.13

This is connected to.

It happens when you have at least 2 panes open and the right one is preview.

Select copy works.

Understood! I did test it with one pane only. The behaviour is as described in this issue:Ctrl+A (Cmd+A) in preview also selects the title (or even the content) of the other notes and subsequently nothing gets copied to the clipboard with Cmd+C after.

If you have multiple panes, then the issue is that nothing even gets selected with Cmd+A

I see that this bug is a bit old, early February. But I am experiencing it now. I’m expecting that text I copy in preview mode will go to the clipboard in rich text. In reality, nothing is happening — nothing is copying at all.

I do see that if I don’t hit Cmd+A, but just use my mouse to highlight the text, then Cmd+C works.

Running Big Sur 11.2.2 on an M1 Mac. Obsidian v.0.12.1.

1 Like

Is there a plan to fix this?

I’ve had this problem for the longest time. Switching out of vim mode in the editor and then back into vim mode fixed it for me. (I see there is now a quiz before letting you do this which was added since I set that the first time. I can imagine that this saves a lot of questions.)

Just chiming in here

I also see the all open panes gets selected issue if I use the cmd+A option in preview mode but paste has the clipboad empty.

In edit mode I get the markdown text and can paste that but not the styled text.

Mac OS Catalina

Still doesn’t seem to work - clipboard empty regardless of how I select text so getting content to Google Docs is difficult.

Logseq got around this by offering a quick ‘export as HTML’ (or plain text) option which saves to the clipboard (with associated mime type set so it pastes in correctly to most applications). It works really well, retaining formatting.

The only workaround I’ve found is to export to a PDF then copy/paste the text from there. Not ideal.

Mac OSX - latest.

I too am having this issue on Windows 10 with 0.12.15.

  • Go into Preview Mode
  • Press CTRL+A
  • Press CRTL+C

Going into a subsequent app to paste does not yield any information pasted from Obsidian.

CTRL+A does highlight all of the text in the preview. I also notice that it highlights the file name at the top.

2 Likes

This is also occuring on mobile (Android) as well. When clicked on “Select All”, the title is also marked as selected, and the toolbar to let you copy and share stuff just simply completely disappeared.

1 Like

It is still a thing on Linux on the current version 0.13.23 and it’s pretty annoying.
But I can use Ctrl-X + Ctrl-V as a workaround as this works.

Steps to reproduce

Start a fresh obsidian vault, create a note with a text body. Toggle reading mode. Select all + copy (ctrl a, ctrl c).

Expected result

I would expect to see the entire note copied, as shown.

Actual result

Nothing is added to the clipboard. I can copy the content if the note title is not selected (only the text body).

Environment

  • Operating system: Win 10
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.14.2
    Installer version: v0.14.2
    Operating system: Windows 10 Pro 10.0.19043
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Safe mode: on

RECOMMENDATIONS:
none


Additional information