⌘C (Cmd C, Cmd+C, Ctrl C, Ctrl+C)

The ⌘C hotkey disappears from the menu (and stops working) after using it to copy something and flipping to another app and then back. (Or at least, that’s the quickest way I’ve found of generating the bug.)

Steps to reproduce

Open obsidian on Mac, use ⌘C to copy something, do not paste.
Flip to another app and back to Obsidian, check the Edit menu, check if ⌘C is still present alongside the Copy command. It’s not.

Expected result

I expect I don’t have to use what I copied before going to another app.
I expect ⌘C to keep working.

Actual result

I can’t use the ⌘C hotkey anymore, although the menu option still works.


  • Operating system: macOS 12.4

  • Debug info:
    Obsidian version: v0.15.9
    Installer version: v0.15.8
    Operating system: Darwin Kernel Version 21.5.0: Tue Apr 26 21:08:22 PDT 2022; root:xnu-8020.121.3~4/RELEASE_X86_64 21.5.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: Minimal
    Snippets enabled: 2
    Restricted mode: off
    Plugins installed: 18
    Plugins enabled: 0


Additional information

I searched the forum quite a bit, using all kinds of different combinations for how to write ⌘C, I’ve searched with Google and DuckDuckGo. This bug doesn’t seem to be documented, much less fixed, anywhere.

It is not the exact same thing as this issue:

I tried another theme, another vault.
Tried deactivating all community plugins.
Tried closing right panes.
From what I can tell, it’s really that ⌘C disappears (and stops working) when you use it and flip to another app.

Which menu does it disappear from? and even if it is not there, does cmd-c cmd-v still work?
Post a screen recording of this happening in the sandbox vault.

I’m only on MacOS 12.3 but this doesn’t happen to me. Does it happen every time, consistently? I can try again after I update, in a week or four.

Your explanation sounds contradictory. You say you check if ⌘C is present in the edit menu, but it isn’t. You later say you can’t use the hotkey, but the menu keeps working. Which is it?

Can you think of any apps you might have installed that have to do with clipboard/snippet management? Do you have any custom keyboard shortcuts that may have been mapped to Cmd-C? Any other helper apps or clues you can think of?

The app’s menu bar, under “Edit”. And no, cmd-c does not work once it disappears. cmd-v keeps working, I can still paste if I’ve used the menu to copy, or paste after copying in a different app.

⌘C is present on launch, it disappears after the steps I mention, then it’s not present in the menu and it doesn’t work.

Can you think of any apps you might have installed that have to do with clipboard/snippet management?

I use aText but there’s no hotkey conflict and I tried with the app closed, same behaviour.

Ah I think I understand. When you use the menu to copy, then this behaviour doesn’t occur, is that right?

So the next step is to try in the Sandbox help vault. And to try disabling your custom CSS snippets. Does it still happen in those situations?

When you deactivated plugins as a test, did you restart Obsidian before testing?

And silly question, but have you tried restarting your computer?

Here’s a screen recording: https://sentiers.media/v/cmd-c_problem.mov (In case the two black windows are hard to tell apart, I’m switching between Obsidian and Safari.)

  • Correct, using the menu to copy still works.
  • I just tried it. Same problem.
  • Yes
  • Yes, even tried the IT Crowd move and it still happens.

I just tried this:

  • Close Obsidian
  • Open Obsidian, open Sandbox help vault
  • Close my main vault (leaving only Sandbox open)
  • Confirm that ⌘C is present under Edit in the menubar
  • Select one word in the Sandbox vault, hit ⌘C
  • Hit cmd+tab to switch to Mail.app, hit cmd-tab again to get back to Obsidian
  • Check the menu bar under Edit, ⌘C isn’t there anymore

This seems pretty weird. Is it possible that you have some SW that interferes with Obsidian?

It’s certainly possible but I’ve been racking my brain and turning things off, still haven’t found a link with anything. :sob:

Do you happen to have Cmd+C set to some hotkey in the app?

Or anything that looks similar to that combo

The key for “copy as html” is Cmd+Shift+C, so very close but I tried deactivating it and restarting. Bug still happens.

I just tried removing every login item, closing every app except Mail, Safari, and Obsidian, then restarting (I even completely uninstalled some small ones). The bug still happens with nothing but these three apps running.

I uninstalled Obsidian completely and reinstalled. Still have the bug.

I don’t see that behavior when I follow the steps to reproduce on MacOS 12.5, Obsidian 0.15.9 (installer 0.15.6, Unrestricted Mode).

I didn’t realise I was one release back for macOS, maybe I’ll upgrade and see if that fixes it.

Hi. Is this still noted somewhere or being investigated? I upgraded to the latest macOS version, hoping it might fix something but I’m still experiencing the issue.

Have you gone through all your MacOS keyboard shortcuts to see if Cmd-C got mapped to something else?

Do you have any hardware like a fancy keyboard that might have custom drivers?

You are using Cmd-tab to switch apps. Does the bug still happen if you switch by swiping with the gesture that shows all windows, and then you click one to go to it?

You talk about apps you have installed. Have you installed any apps through developer means, such as command line or Homebrew? Apps you might have forgotten are installed because they arent in /Applications? No need to list them. Just remember them.

  • Yes, no conflict. (Plus, wouldn’t that cause a problem everywhere, not just in Obsidian?)
  • None.
  • I had tried using the doc, same bug. I had tried clicking another window, same bug. I just tried the gesture you mention, same bug.
  • I had Geektools and Jumpcut, I deleted both and it’s part of the reason I upgraded the OS, hoping to overwrite something they might have changed. That being said, neither were using Cmd-C (Jumpcut was using Shift+Cmd+C) and if they were the source of the problem, it would happen in all other apps, no? (I do have a number of other things installed with homebrew, but for web dev, not things that are “surfaced” in the OS’s UI.)

Not sure why the above didn’t stick as a reply but it’s a reply :wink: