Blank / Black / White screen on startup / launch / open

If obsidian doesn’t start properly and it shows a blank/black/white screen, It’s possible that some plugin is causing Obsidian to crash and the crash is unrecoverable.

To restore obsidian, use the following procedures on your vault. If you have multiple vaults and you don’t know which one has the problem, you need to try in all of them.

Begin

  1. Close Obsidian
  2. Download and reinstall Obsidian from the website
  3. Start Obsidian.

If it load great, go to Final Steps. If it doesn’t work try Procedure A

Procedure A

  1. Close Obsidian
  2. Using File Explorer/Finder, go to the folder that contains your vault’s folder.
  3. Rename your vault folder
  4. Start Obsidian

Obsidian should open and show you the vault selector, select your vault using the new name.
If it load great, go to Final Steps. If it doesn’t work try Procedure B

Procedure B

  1. Close Obsidian
  2. In File Explorer/Finder go inside the folder corresponding to your vault.
  3. Make sure you can see hidden files (On mac, press cmd-shift-.)
  4. Move the .obsidian folder out of your vault to another location
  5. Start Obsidian

At this point, Obsidian should start on your vault with default settings and no plugins. You can reconfigure your vault via the UI from scratch or you can attempt to copy your previous settings and plugins from your old .obsidian to your new .obsidian a little bit at the time and see if still works.

Final Steps

Make sure your themes and plugins are up-to-date by checking for updates inside obsidian.

3 Likes

I have the same problem ocasionally. Usually, before it goes black, there is a time-window, in which I can access the settings and update the plugins. So far, this has always solved the problem for me.

Thanks again, Whitenoise! It’s still not working unfortunately. Same screen as before and described in the other thread. What else can I do?

Could it be an issue that I am accessing the obsidian vault with multiple different versions of obsidian?

which multiple versions?

I’m using the latest iOS version, the older version on my mac and 1.5.3 on my macbook to access the vault.

I just want to add something in case anyone else is still struggling like I was.

I am running an older version of macOS (Sierra 10.12.6) on an old 2013 Macbook Pro Retina. Crazy I know but I have a good reason for doing so and am working towards being able to update soon but my life is, well… busy!

I had the same issue suddenly last week. All I can think of is that Obsidian somehow managed to update from the 1.0.3 install which is the last one that works on my outdated system and that caused havoc. Or maybe the fact that I sync everything in my vaults with machines that run newer versions of Obsidian has finally caught up with me. We shall see on Monday…

I tried what was mentioned above but that did not work.

What I then did was make a backup of my .obsidian folder - just in case.

Then I uninstalled Obsidian.
Then I went to the

/Users/username/Library/Application Support/obsidian

and deleted it all.

This did the trick.
After re-installing “Obsidian-1.0.3-universal.dmg”
I immediately disconnected my WiFi just in case it was updating without me knowing it. Then I went to the Obsidian “About” page and disabled automatic updates.
Then I re-enabled my WiFi and all has been good. Things are working.

BTW I also sync my vaults using Syncthing and use them on other windows machines with the latest version of Obsidian and things seem to work.
My syncing is a bit hokey, I need to spend some time and not sync some files, but overall it works and is usable for me.

see Black window is drawn instead of opening the app v1.0.3

This may be n/a for most, but might help someone.

My scenario was having a very old version of obsidian installed, and possible complications with obsidian trying to automatically update itself.

The workaround for me was to disable automatic updates in settings/about, and remove the obsidian-1.5.3.asar file in %appdata%/obsidian.

Brilliant! That did the trick. Thanks so much, Frostyfriday… really appreciated

1 Like

I made an account just so I could reply to this. I’ve been searching for a cure for the last three months and couldn’t find anything meaningful. Your situation was almost exactly the same as mine. Old Mac, got the sync, but shortly after that, my computer application stopped working. I followed your steps and everything is back to normal. Thank you so much.

1 Like

Thank you. It worked. Same situation - old Mac, I don’t even know when Obsidian updated itself but this morning I got a white screen on startup. Your post helped me get it back to normal. Thank you very, very much.

1 Like

Obsidian black screen bug reports replicated by multiple users have been unlisted. Why? - Meta - Obsidian Forum