No spellcheck suggestion for one language when using multiple languages

Steps to reproduce

Create a new vault, activate both ‘English’ and ‘German’ in the editor settings as spellcheck languages.

Create a file and insert this text:
Deis ist ain Baispiel führ einen Sats.
Thiss is an äxampel fohr a säntence.

Expected result

I’d expect to see spellckeck suggestions for the misspelled words in both languages.

Actual result

Only suggestions in the first language are shown (in this case English).

Environment

SYSTEM INFO:
Obsidian version: v1.3.3
Installer version: v1.1.9
Operating system: Windows 10 Home 10.0.22621
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none


Additional information

I already opened a thread with the same issue quite a while ago:
No spellcheck suggestions when using more than one languages - Bug graveyard - Obsidian Forum

Unfortunatley, it’s still not solved.

How many vaults do you have?

On chrome, with the same languages, which suggestions do you get?

To test, I removed all vaults except one with the spellcheck-document: same result.

I don’t understand how I could use Obsidian with chrome? I am using Obsidian under Windows 11.

This is an electron bug - I have filed an upstream bug report here:

I read the discussion about the bug in Electron in a way, that it has to do with how the languages are referenced (EN-en, DE-de vs en,de).
I’d like to try this out in Obsidian. If - as a workaround - I could find a configuration in which at least German (my primary language) would show suggestions while both languages are marked with the red lines, that would help. Currently only suggestions for English are shown, which I don’t use that much.

Problem is, I can’t find any configuration file where the spellcheck-settings (like languages chosen) are stored.

Where can I find them?

Stefan

Same problem here, I hope that the electron team are able to solve the bug.

Steps to reproduce

  • Tested on Windows
  • Go to Sandbox-Mode
  • Add English and German to “Spellcheck languages”:
    grafik

Make a German spelling mistake:
grafik
The correct word is known by the dictionary. But it will suggest anything but that word.
e.g:
öglichkeit => Missing “M”, Suggestion is “Lichtenstein”
Möglickeit => Missing “h”, Suggestion is “Magicked”
Möglichkei => Missing “t”, Suggestion is “Heimlich”

Is it possible, that the suggestions are only taken from the English spelling dictionary?
Either way, the suggestions does not match the misspelled word, that is only missing one character.

Did you follow the troubleshooting guide? Y

Expected result

Reasonable suggestion for the German spelling error.

Actual result

A suggestions that is not even vaguely matches the erroneous spelling.

Environment

SYSTEM INFO:
Obsidian version: v1.4.16
Installer version: v1.4.13
Operating system: Windows 10 Pro 10.0.22621
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none

I have the exact same issue on Obsidian for Mac.

Did you find a solution?

Unfortunately not.
I helped myself by just using one language for spellchecking (German) and switching the spellchecker on and off when I use English text. :man_shrugging: