No spellcheck suggestions when using more than one languages

Steps to reproduce

Just open any vault (i.e. the sandbox demo vault), activate spellcheck in the editor and add a second language (German and English US in my case).

Expected result

Until recently (might be prior to 0.15.06), suggestions in BOTH languages would be displayed.

Actual result

Type dual language sentences with misspellings like this one:

When right-clicking a misspelled German word, nothing is suggested:

When switching off English US, it works (for German):

Wrong spelling is marked correctly for both languages, suggestions are only made for English.


  • Operating system:
    Windows 11
  • Debug info (Sandbox Mode):
    Obsidian version: v0.15.9
    Installer version: v0.15.6
    Operating system: Windows 10 Home 10.0.22000
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 0
    Restricted mode: on


Additional information

what happens if you add both languages and restart obsidian?

There are some problems with spellchecker we haven’t put the finger on where the issue is. Likely an upstream bug.

Exactly the same.
You can easily reproduce with an empty vault in the sandbox.

If it at least would be possible to change the order of the languages, that would help.
German is my primary language, English only used in rare cases, so I need suggestions for German much more often than English.
But each time I add both languages (no matter which one is added first), English is always on top (I guess they are ordered alphabetically). Result is, I only get suggestions for English.

I can’t.

I can use multilingual. Also when you use to multilingual, you should not expect to get the same results as if you were using English alone and German alone.

try to download and reinstall obsidian.

That’s curious.
I downloaded and installed obsidian, created a new vault (all default, no plugins), activated spellcheck with both languages: same result: suggestions are only shown for English.
Crosschecked with another language (Italian), now only German suggestions are displayed (so I assume always only the first language in the list).
Checked the same with a new user on my computer and a fresh Obsidian installation, same result.

Anything else I can do to narrow down the cause of the problem?

Hmm. I can’t reproduce this either. With German + English UK and/or US, I get relevant suggestions in both languages. Tested in a new vault, also works as expected. (I re-used your example sentences for reference.)

now it’s getting really interesting.
What else could I try?
As mentioned above: even with a clean and fresh installation with a different user-account on my windows 11 machine I can reproduce the behavior.
So, what can be so special about my system?? :thinking:
(it’s well known that I am a very special guy, but my computer?? :stuck_out_tongue_winking_eye:)

when you do right-click to get the list is it slow? does it freeze?

No, pops up lightning fast

1 Like

I am seeing the same issues, almost.
If I have two different languages like English (UK), Serbian I loose option to have spellcheck,
If I have two different languages like English (UK) and Swedish (French or German) spellchecker is working

So its the issue with some languages. Maybe Serbian used here is Cyrillic script, and the rest of text is not cyrillic so that is what messes up.
Not sure.

The spellchecker is broken for me. Dual language. Most of the words (but not all so it doesn’t even make sense) are underlined and suggestions are mixed up (English suggestions for French words, French suggestions for English words) like if the spellchecker was confusing the two languages.