Android/Gboard: Can't create new line in notes (Return/Enter)


[ ] iOS
[x] Android

Obsidian Mobile version: v1.4.2

When pressing enter on my keyboard, Obsidian won’t create a new line in any file, except for when:

  • The current line is empty,
  • The current line ends with a punctuation mark,
  • The file has an (empty) line below the current line.

This bug does occur for me when:

  • The current line ends with a word without punctuation mark and is the last line in the file.
  • The current line ends with a word without punctuation mark and is a heading. Even with an empty line below it, a new line won’t be created.

This occurs for me on my current vault with default theme and restricted mode on as well as on a brand new vault.

(I also noticed that on Windows (with the cursor at the end of the inline title) pressing enter once will take the cursor one line down, doesn’t work on Android. Instead I have to quickly double press enter for the same result. Not sure if this is related.)

Using Gboard on a Google Pixel 7 Pro.

Curious if anyone else has this issue! Thanks.


works for me

If you create new vault on Android, do you still have that issue in the new vault?

Yes. I do, unfortunately.

I have the same issue on the beta Gboard

I uninstalled the beta to this version and the issue is gone.

Also having this same issue, also using Beta Gboard - I’m trying the standard version now to see if that fixes it.

Yep, that fixes it - seems to be a gboard problem

I just started having the problem on Google Pixel 7. Standard keyboard installed.

Gboard version:

This issue happens when either “Auto correct” (“Correction automatique” in french) or “Spellchecking” (“Correcteur orthographique” in french) options are enabled in the Gboard settings.

When one of the two (or both) options are checked, you’ll see the word underlined as if the keyboard wanted to show alternatives to the word. That’s when the line return doesn’t work.

Obsidian is the only app I have which has this input bug.

Pixel 6, latest non-beta Gboard as of 21st of March.

My bet is that when @anjabeth will update Gboard, line returns will not work anymore.


I’m on the Gboard beta and I have the same new line issue related to auto correct.


Same issue, with non-beta Gboard. Started a few weeks ago. I’m currently working around it by putting an extra space at the end of each line, but that’s a bit annoying.


I have the same issue, also with the non-beta Gboard. But I have all auto correct features of Gboard disabled

@tmk @ironeer, Which version of Gboard do you have exactly. I still can’t repro on

I’m on non-beta version on a Pixel 6 Pro and I have this issue too.

I also have this issue on

Workaround: I am using Microsoft SwiftKey until this is solved

1 Like

Been seeing the same behavior as well for a few weeks (beta gboard, but now stable has also been updated).

@WhiteNoise If the version hasn’t rolled out to you, it can be downloaded from APKMirror.

Same experience here. Pixel 4 with default Gboard

I tried turning off options and it seems to be present when any of these are active:

  • Autocorrect
  • Spellcheck
  • Grammar check
  • Suggestion strip

If you turn these all off you can get it to behave normally but this isn’t practical long term.

The issue isn’t present in other apps, egg the default Keep notes, so I’m guessing it’s something to do with either Obsidian’s smart commands or custom keyboard strip for markdown styles.

I tried an apk for and it works fine for me.

Everybody having this problem please provide

  1. you phone make/model
  2. the gboard version.
  3. a screen recording of this happening in a new vault.

Same problem here, with Google Gboard and Obsidian 1.4.3

This is me trying to put a line break after a Heading 1. I have to let an extra space in the end of the line to make it happen.


My phone is a Samsung Galaxy S20+

1 Like

Same here on Pixel 7 Pro; had to also disable the “Show suggestion strip” option. Would love to see this bug resolved!