Enter in Lists on Android/Gboard doesn't make next bullet point, checkbox, etc (due to autosuggest)


[ ] iOS
[ x] Android

Obsidian Mobile version: v1.4.1

When using bullets or checkboxes on my phone, when I get to the end of the line and hit return it (usually) does not create a bullet/checkbox on the next line. If I hit backspace and hit return again, it (usually) does create the bullet on the second attempt.

I am a big fan of bulleted lists and like to use mobile for quick capture so this behavior is quite annoying, especially when using nested lists.

I am currently using the Minimal theme, but the behavior seems to be theme independent.

Likewise, I have tried turning off all my community plug-ins and the behavior does not change. I suspect it is an interaction between Obsidian and Gboard, but that’s about as far as I have gotten.

Has anyone else had this problem? Has anyone solved it?



According to discussion starting at Discord it’s a known bug, so there’s probably a bug report here in the forum.

EDIT: Someone’s added on to that, saying that adding a space before return helps.

Thanks! The space does seem to help. I assumed it probably was a known bug, but was having trouble finding it with search. I appreciate your taking the time to help.

Came here to report the same thing. Adding a space helps but is annoying.

Removed “[Bug]?” from the thread title because the problem isn’t caused by Obsidian.

I was able to repeatably reproduce this and I’ve found that it’s entirely due to Gboard’s autocomplete system.

I’ve found two ways to replicate it:

  1. Type a word and have Gboard autocomplete it as the last word in a list
    (a good example is the word I'll but without the ')
  2. Use a suggestion from above the Gboard keyboard as the last word in a list

I’ve not (yet) found any other ways to reproduce this.

As for ways around the problem, one way is of course to turn off auto-complete.
But that’s no fun :confused:.

Another is to notice when a word has been corrected, or when you click a word suggestion and make some other edit to that same line.
You could add a full stop, delete the inserted space, or any other text edit (I think).

Personally I think I’ll either try to go for full stopped lists (yuck) or try to notice when there’s a space at the end of a list and delete that before hitting enter.

Watch out for Gboard correcting the last word in your bullet list!


I’m having the same issue. Using Gboard. Hope this gets resolved soon.

This problem is due to Gboard autosuggest/autocorrect feature. You need to complete that word (with a space or dot) and then make a new line.


[X] iOS
[ ] Android

Obsidian Mobile version: v1.0.4

Normally, hitting enter at the end of a list item will insert a newline followed by the markup for a new list item and place your cursor after it.

However, if the system autocompletion attempts to trigger on the final word of the list item, when you press enter it will instead add a new list item on the next line then another newline, with your cursor winding up on the final non-list-item line. It also won’t make the autocompletion substitution, which I would normally expect pressing enter to do.

I assume this is the autocomplete and the markdown-editor stepping on each other’s toes somehow.

I can make a video if this was unclear…


Steps to reproduce

  • start a new un-ordered list ( or task list )
  • type in an item
  • click enter to proceed to the next line

Expected result

I expect to see a new entry in the list with the cursor placed after the list entry symbol

Actual result

a newline is entered, a new entry is not added to the list. The cursor placed on the next line at the start of the line. ie - essentially outdenting from the previous list entry.


  • Operating system:
    I’m running Android 13 on a Pixel7 Pro
  • Debug info:

Operating system: android 13 (Google Pixel 7 Pro)
Obsidian version: 1.4.1 (83)
API version: v1.0.3
Login status: logged in
Catalyst license: insider
Live preview: on
Legacy editor: off
Base theme: light
Community theme: Minimal
Snippets enabled: 0
Restricted mode: on

Additional information

this happens pretty consistently. However when I manually place the cursor back at the end of the last element in the list and hit enter again - obsidian behaves as expected. ie creates the new element in the list.


update - this happens 100% consistently for me. It makes list editing on mobile quite a frustrating process.

1 Like

This is also 100% reproducible for me, on Android. It really makes Obsidian more or less unusable for taking notes on Android.

Hello, I’m having the same issue described above. If it’s a gboard bug as is the consensus here, then other apps have compensated for it. Here are screen recordings from Obsidian and Google Keep:


I believe it could be related to this problem:

Because of that problem I’ve downgraded off the beta version of gboard but this bullet problem persists. I’m on gboard version 12.6.02

Operating system: android 13 (Google Pixel 6)
Obsidian version: 1.4.3 (95)
API version: v1.1.16
Login status: logged in
Catalyst license: none
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 2
Plugins enabled: 1
1: Auto Link Title v1.4.1

Thanks for taking a look!

Steps to reproduce

  1. start a numbered list with check boxes “1. [ ] task”
  2. create at least 3 lines
  3. go to line 1, at the end, and type enter
    —> all checkboxes disappear from lines 2 (the new one) onwards. This means that the previously existing checkboxes in the lower lines are also removed

Expected result

→ the new line (after step #3 above) should display “2. [ ]”, and all following lines should keep their checkboxes

Actual result

All checkboxes from lines 2 onwards disappear


  • Operating system:
    Mac OS Ventura 13.1
    Android on Samsung Galaxy 22 Ultra, version 13

  • Debug info:

Additional information

On the Mac, this started to happen after the update to version 1.1.16. Previous versions on Mac did not have that problem

No the one mentioned in 1.4.4 is a different problem.