Swiftkey + Android voice-to-text bug?

Hi. Im wondering if anyone else is getting this problem or can help.

  • I use Swiftkey on my Android (Xiomi Redmi Note 10 pro) and until very recently had no problem accessing voice-to-text in Obsidian mobile. But it’s suddenly stopped working.

  • The voice-to-text panel will not open - it tries to open and immediately closes.

  • When I switch to Gboard, voice-to-text works fine.

  • All relevant permissions are on in Swiftkey, I didnt change anything to make this happen (afaik).

  • Swiftkey voice-to-text works fine in all other contexts.

  • Ive rebooted, and uninstalled/reinstalled Obsidian.


Further update, in case anyone else encounters this problem. Swiftkey for some reason seems to force permissions off for the microphone, so this is a SwiftKey problem, but possibly caused by interfacing with Obsidian. If you go to turn them back on manually in the microphone permissions (not SwiftKey permissions) you can manage to get the permission to stay on. Hopefully.

More tests:
After clearing all cache (using Mi Cleaner, there isn’t a cache partition), and rebooting/power off several times, plus double checking all permissions. Swiftkey will open once in Obsidian mobile, then will not open again.

What appears to be happening: the voice-to-text panel opens then immediately switches ‘off’ and disappears. The panel seems to be open ‘underneath’ the Swiftkey keyboard. If you click into empty Obsidian file pane, you can momentarily see the white panel ‘roll up’ as the Swiftkey keyboard comes back into view.

This does not happen using any other app with Swiftkey keyboard.

clear the app cache and cookies of the obsidian by navigating to device setting>app>obsidian>storage>clear data and cache.

Thanks, I will go and try clearing all data for Obsidian.

I cleared the cache as first thing to try, but it made no difference, and cleared cache for SwiftKey. I also uninstalled and reinstalled both apps. very weird problem, I believe its a conflict between Obsidian mobile and Swiftkey as Swiftkey voice-to-text works fine everywhere else. I still haven’t solved the issue.

Update: no, doesnt solve the problem. I removed all hidden files and folders manually and cleared all data from the app. Swiftkey still only opens voice-to-text once (when you first open Obsidian), then wont open at all.

I’m having the same exact problem using SwiftKey. In obsidian mobile the microphone key no longer brings up the voice to text function it closes immediately. It does same thing with Samsung voice or Google Voice. I tried switching keyboards to Google keyboard and it still does the same thing. The only thing I have found to make it work for a while is to restart my phone. Does anyone have any other ideas to make it work? The keyboard works fine in every other app it only seems to be a problem in obsidian mobile. Thank you for the help and the input

Very interesting, thanks for your input. I think we may have discovered a bug between SwiftKey and Obsidian mobile. But our use case bug is slightly different. To summarise my experience:

  • Restarting makes no difference to my issue (on the Redmi note 10 pro). I rebooted multiple times between uninstall/reinstall both apps (separately), and after clearing both caches, all device caches, and after clearing all data for Obsidian mobile.
  • Gboard voice-to-text works fine, including in Obsidian mobile, ONLY SwiftKey break voice-to-text in Obsidian, but nowhere else

Lets keep trying to solve it/find a solution. I’m posting this today into the Reddit Obsidian MD group.

I just tested to help. I have the same problem.
With Swiftkey, the keyboard closes immediately when I try voice-to-text.
On the other hand, it works perfectly with Gboard and the Samsung keyboard.

Hey. Thanks for testing. So when you’re using SwiftKey does the voice-to-text blue button stay open or does it disappear immediately? For me it disappears straight away. When my default keyboard is Gboard it works.

Same as you. It disappears immediately. And when I click on it, it disappears, but then I change applications and go to a text box, the voice-to-text blue button reappears right away.
And with Gboard, the voice-to-text blue button remains fine and works well.

Tx. I’m going to test some other keyboards to see if it does it with others.

I made a gif so that its clear to other readers what we are talking about.
Gif of swiftkey/obsidian voice-to-text bug

I’m having a similar problem. I use Gboard, but for some reason, when I try to type with voice-to-text it stops typing after a single word. But his seems to only happen with bullet points, headers, or any formatted text. Regular text is fine. Can one of you try voice typing a bullet point with Gboard to see if it works?

As for MS Swift keys. I recently installed it and the voice-to-text in Obsidian doesn’t work at all for me either. Could this be a bug from a recent Obsidian release? Or did Swift keys change certain settings that messed with Gboard as well? This is frustrating… This seems to have just started happening today.

  • @avalancher Thanks for confirming the issue with SwiftKey. Yes its possibly an issue with Obsidian mobile update and SwiftKey conflict.

  • @Anwen and @avalancher Can you provide your phone models please in case it is a bug?

  • @avalancher re voice-to-text/Gboard bullet point punctuation - I tried using various voice commands to make unordered lists (insert bullet, insert list etc) and cant make it work. On Android most voice-to-text punctuation commands dont work in my experience.

I experience the same issue with GBoard - you can only voice input text into regular (unindented) text.

I switched to Swiftkey to see if the issues persist to discover that it’s even worse here :slight_smile:

1 Like

hi @onkeltem

Thanks for reply. Can you describe what happens when you have SwiftKey as default keyboard and then try to use voice-to-text?

(NB The Gboard formatting issue is a digression from the topic of this thread which is about Android SwiftKey bug with Obsidian mobile and voice-to-text not opening at all.)

I have a Samsung S22, so with Android 14.

1 Like

I think the bugs might be related actually. I’m not refferring to using voice-to text to create the bulleted list or heading itself. With the bullet or heading already created - In Gboard, it writes a single word and then immediately closes. In Swiftkeys, it opens and closes immediately. This seemed to work fine before the update.

I have a Oneplus 7T with Android 12.

1 Like

I have another thread for Gboard issues actually. If anyone has voice typing issues specific to Google Gboard, please post here instead:

1 Like

thanks - sorry if I sounded a bit snarky, just wanted to keep the thread on track. Maybe I should make a thread in the bug topic that documents the SwiftKey issue.

1 Like