Special characters are being merged?

What I’m trying to do

I want to stop Obsidian from reformating or changing characters.
For example, if I want to write =>, ->, <= or >=, Obsidian is reformatting those to a short form:

Looking from the “Source” mode:

image

Notice the first and second, the equal and the greater-than sign are merged.
Same with the hyphen and greater-than sign.

This does not happen on the 3rd and 4th.
But it does happen again on the math expression.

And if I open the notebook in the “Live Preview” mode, it looks like:

image

I prefer it if Obsidian does not replace the characters.
How can I do that?

Things I have tried

This is the text I am using:


```
=>
->
```

=>
->

$=>$
$->$

Same happens on a Sandbox vault:

Any ideas?
Thanks!

Which operating system are you using? If you’re using MacOs have you checked that your keyboard doesn’t have shortcuts defined for these combinations?

Thank you for your reply.
I am using Windows 11. I have an US ANSI keyboard.

Strange that only the characters are being reformatted or converted in a few cases inside Obsidian.

And if I copy and paste those reformatted symbols, and paste on Notepad, the symbol is in the expanded form.

Also I a tested and checked on Notepad and Visual Studio Code, and the .md files are normally formated. I mean, the => are two characters.

That most often comes from font ligatures.

I see the same in the Sandbox on Windows 11. Whatever the default monospace font Obsidian is using has those. I don’t see it on macOS.

If you change Settings > Appearance → Monospace font to a different monospace font without ligatures, it should be fine. I randomly picked Source Code Pro (not sure if that’s in Windows by default) and the => weren’t combined in the code block.

4 Likes

Do you have Smart Typography or another plugl-in installed?

Thank you @ariehen for your reply.
Was that.
For some reason, before I did not have this “issue”.

On Windows 11, the default monospace font for Obsidian was Cascadia Code, and this one has ligatures.

I changed it to Consolas (the same used by VSCode and Notepad), and now I don’t have ligatures. Same as it was before.

Now, on “Live Preview” looks like this:

And on “Source”, like this:

Thank you all.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.