Properties Plugin doesn't forget some unused Keys

With the release of 1.4.5 I played around with the new properties plugin, some of the fields i’ve created with random names like “Car” or “Testfield” are not beeing forgot now and are lingering around in the “Show All Properties” Tab showing 0 matches for my Vault:


These keys also populate the Key suggester when adding new properties.

I would expect Obsidian to forget Keys that are not being used in any files. It doesn’t happen always though. I’ve tried entering and deleting keys again and they got properly forgot.

I’m on 1.4.5 Linux .deb
Installer Version 1.4.5

We don’t remove registered properties automatically (in case you plan on using them again in the future). But you can manually remove them by just right-clicking in the All Properties view and clicking “Unassign type.”


I see. Thx for the reply. I’ve noticed the “Unassign Type” Option on right-click. But it doesn’t remove the properties for me.


Can they be removed manually by editing a settings file somewhere?

Cheers :slight_smile:


Interesting, there might be a bug with that. I’ll take a look. Thanks!

Okay, found the bug with “Unassign type” and it will be fixed for the next version. Sorry about that!


Thats great. Thx a lot :).

Btw. i’ve also noticed, that the default types “tags”, “cssclasses”, and “aliases” can be unassigned aswell. Maybe it would be good if they couldn’t be unassigned. I’ve tried unassigning the “tags” type and it disappeared and by entering a new property called “tags” it lost its native behaviour, like auto suggesting existing tags and the distinct icon. All the unassigned default properties come back after a restart of Obsidian. But it spooked me a bit, so that i felt like I broke something. First time that happened I reinstalled Obsidian before I noticed a restart brings them back.

1 Like

Oops! Great catch, I swear that used to be the case, but it looks like we accidentally broke that. Will also be fixed for the next build.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.