Obsidian Sync not syncing plugins and settings

Things I have tried

Followed: Introduction to Obsidian Sync - Obsidian Help
Searched the forums but couldn’t find an identical topic.
I have tried activating sync addon and add vault to sync after to a local vault.
Chosing to sync everything, plugins settings.
Restart app, nothing on any devices syncs. Only the texts sync.
Tried deleting and starting over.
Uninstalled app and reinstalled.

What I’m trying to do

I have setup two vaults, one private and one work.
The md files syncs to work computer, work phone, and private phone from my private pc.
But no other settings or plugins at all.
This was a big reason for me to pay for sync, to not have to bother with syncing settings on 4 devices.


It works for me.

Can you post a screenshot of your sync settings page? One for each device.


Using Obsidian Sync between android and ubuntu desktop, text files sync effortlessly. I want to sync the Graph View settings as well. To this end I have enabled the following sync settings on both devices:

  • main settings
  • appearance settings
  • themes and snippets
  • hotkeys
  • active core plugin list
  • core plugin settings

But I still don’t see a successful sync regarding the graph view settings such as coloured groups? What am I doing wrong?


I’m also having this problem, syncing between iOS and Linux. Every sync option is enabled, messages sync fine, no errors listed in the sync log… but settings and plugins remain entirely separate.


For some reason my Graph view settings finally synced from ubuntu to android. I am not sure how it happened.

After enabling the previously mentioned sync settings on both devices, I made one change in the graph view settings on ubuntu, which contained the settings as I wanted them everywhere. A while later they appeared on android.

1 Like

A lot of people have been struggling to understand and configure settings sync.


For me, the confusion is:

I like obsidian a lot, but settings sync is by far the most confusing part. Text sync is totally intuitive and works just like you’d expect. Settings sync, imo, is the opposite.


Just wanted to report back. I took this to the priority support email, but they were not able to resolve the issue. After seeing that the logs and screenshots (they refused to move forward until I sent these, despite my describing the contents) were as I described and didn’t shed light on the issue, they stated that we were “at an impasse”.

As I only have two more days before I won’t be able to get a refund for the service, I’ve gone ahead and canceled. I will probably continue to use Obsidian, but through iCloud Drive. I lose Linux access, but settings and plugins sync works.

Ok, I am going the leave here for posterity some troubleshooting ideas

I am going the leave here for posterity some troubleshooting ideas if you have issues with sync and especially with syncing config.

  1. Sync hasn’t finished syncing yet
  2. You didn’t enable sync of settings or plugins in one of the devices involved
  3. You didn’t restart Obsidian on ALL involved devices after enabling/disabling any of the sync options
  4. You didn’t restart Obsidian on ALL devices involved after making any change to a plugin configuration (obsidian’s own setting live reload but the plugins’ settings do not. They change on restart)
  5. Sync is stuck on some file (Does it say fully synced on ALL devices)
  6. You use different settings directories (.obsidian)

I am going to close this thread. If you have issues with Sync open a new thread.