Syncing Settings doesn't work at all

Hello together,

I am using sync since I am using multiple devices (mac, windows). Sync did exactly what I could already have done by syncing to my icloud, mainly just importing files.

Other than that, nothing happened.

I’ve been using obsidian for quite some time on my macbook and there are all these tiny little amendments I made over time (for instance where the small graph preview is, community plugins etc.) that I don’t even remember how to even set it up from scratch again.

Is there any reason why the settings don’t sync? I just want to have the same layout on my windows pc than I have on my macbook.

Thanks for any help

sync settings works. Perhaps you didn’t configure it?

1 Like


did you do this on both your devices?
Are you using different configuration directories?
Sidenote: Always have a backup.

I have the same issue as @chrtpmdr. Sync is enabled and configured (everything checked on, as in the screenshot above) - both on the iOS app (1.0.4) and Linux app (0.12.15). Changes inside notes do get synced just fine immediately. I noticed that the change actually gets propagated - it’s shown inside the Sync Settings log. It’s just not applied - doesn’t matter if it’s phone->desktop or the other way around. I have to reopen the vault to apply the change.

Steps to reproduce:

  1. Make sure that sync is configured on both sides and all settings checks are enabled.
  2. Inside the mobile app, toggle for example the “Base theme” select box under Appearance.
  3. Inside the desktop app, go to Settings → Sync → Settings version history (View) → .obsidian/appearance.json
  4. Check that the “theme” JSON field (moonstone/obsidian) has been changed.
  5. Go to Appearance. The “Base theme” didn’t get updated. The app has also not changed the theme.
  6. Close the vault and reopen it. The app theme should be changed now.

Is this a bug or works as expected? Thank you.

Jumping in with the same issues here.

Sync is enabled and configured on windows(0.12.15), ipad(1.0.4), and android(1.0.4). Notes sync, but none of the settings, plugins, themes, etc.

I tried to create a separate settings file for my ipad by copying the functioning original .obsidian directory and renaming. changed to new directory on ipad. ipad app is still showing no plugins or themes available despite all being there in the directory.

Running out of ideas on what to try next.

Same issue for me.
I have Obsidian (0.12.12) installed on Windows 10 and Ubuntu 18.04.5
I have sync enabled on both OS’s for:

Bit I only get Documents and attachment synced.
All settings doesn’t sync. I do it manually

@WhiteNoise Wich Is there any additional information I can provide?
Also Should we move it to #bug-reports ?

do you use custom location for your .obsidian directory?!?

Do you get errors in console? What does the sync log say?

Got it working after update to v0.12.15 on both PC’s :tada:

1 Like

I have a similar problem here with my sync settings. I’m just moving from vault over from icloud to Obsidian Sync, and my notes sync across without a problem, but I have no luck with the settings. Tried both options - 1) having one .obsidian folder for settings, as well as 2) a specific folder for mobile (called .obsidian-ios. This is how I sync on icloud at the moment).

No errors on the sync log. So not sure what’s happening.

@WhiteNoise I do have two separate folders for my settings files - .obsidian for the desktop and .obsidianios for iOS. Does that create a problem?

if you have two separate folders they are gonna sync separately.

Thanks, I meant - I have two separate settings folders in my vault, and it seems like the one titled .obsidianios does not sync. Only .obsidian syncs. Any reason why that may be happening?

@Mavalator what is your complete setup? how many computer and and idevices do you have?
DId you check the sync settings in all these devices?

I just solved it, thanks for your reply. I have a mac (that is using the main .obsidian settings), and a iPhone and iPad using a second set of settings (called .obsidianios).

In the end what I did was create a new settings folder on the iphone, rather than using the folder that was already in the directory. I then copied over contents from my legacy (.obsidianios) folder into this new settings folder created by the iphone. The problem was that the legacy folder was just not being recognised by the iphone or ipad.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

I am going the leave here for posterity some troubleshooting ideas if you have issues with sync and especially with syncing config.

  1. Sync hasn’t finished syncing yet
  2. You didn’t enable sync of settings or plugins in one of the devices involved
  3. You didn’t restart Obsidian on ALL involved devices after enabling/disabling any of the sync options
  4. You didn’t restart Obsidian on ALL devices involved after making any change to a plugin configuration (obsidian’s own setting live reload but the plugins’ settings do not. They change on restart)
  5. Sync is stuck on some file (Does it say fully synced on ALL devices)
  6. You use different settings directories (.obsidian)
1 Like