Bible Study in Obsidian Kit (including the Bible in Markdown)

I tried for several hours today to get this to work (Windows 10) and couldn’t get the script to download ANY Bible translation (even default WEB). The script works to create the folder structure and files, but does not seem to ‘paste’ the actual scripture, just the references. I get a constant: “bg2obs.sh: line 148: ruby: command not found” error.

Any tips?

I have installed Perl, Ruby, Bash etc. and everything seems to run properly other than the fact that it seems the script isn’t finding the ‘bg2md.rb’ Ruby script (regardless of whether I paste it into the same root folder or not).

image

Thanks @Ka_upkah and @bmwhite1611 for letting me know! I actually added a The Bible.md file in the repo now!

Sorry @corsair2014, I am not on Windows and therefore the script isn’t written to be run there. Maybe the community can help out!

Have you tried if the original BibleGateway-to-Markdown script works? That can help to isolate the issue.

Joschua,
Yes the Ruby file runs on its own but the ‘copy’ to clipboard functionality yields a memory allocation error… perhaps this is why the files come out blank with only the verse references.

Thank you @Joschua and @joebuhlig for this. Quick question: I got the markdown files generated but I don’t have the navigation links at the top of each chapter for the previous chapter | book | next chapter. Did I miss a step?

Did you install the clipboard gem? If yes and it still doesn’t work, you can also just delete the references to clipboard (L78 + L460) in the script. Maybe that helps.

@m.wilson55, sorry I’m not sure what went wrong. Did you use @joebuhlig’s version of the script or bg2obs.sh? And which OS are you on?

This is so good thank you! I have been enjoying the Bible in a Year podcast with Father Mike Schmitz and just jotting down some notes on my Daily - this will help me be far more intentional and be able to link the referenced scripture! This is so amazing, thank you. The instructions on GitHub were all very clear and easy to follow as well.

edit to add: The Revised Standard Version Catholic Edition (RSVCE) seems to be installing fine for me so you can add that one to your list of versions it looks okay with (if it wasn’t already there).

Oops, I think this should have been @Joschua - sorry!

1 Like

I have been pondering verse range links using @Joschua’s Bible Study Kit. By adding a beginning level 5 header for the range and then an ending level 5 header around the level 6 headers in the verse range, I am getting a friendly link that reasonably shows and links to the range. I thought I would share my results.

1 Like

Hello all! New to this post but found this could be an amazing place where I can customised my very own bible reading tool from here. I tried to followed joebuhlig’s BibleGateway-to-Obsidian way and successfully get the Bible text from BibleGateway, but until the “4. Split each virse to it’s own file” part I think I encountered some problem there.

When I run the bash versesplit.sh to split the chapters in to seprate verse files, I found that all the content within the Bible chapter folder would gone. I’m not sure which parts I did it wrong and would like to see if anyone could point me a fix or direction?

Here’s a screencap before I run the script:

Here’s what happened after the script:

p.s. I tried another round to run the “bash rename-folders.sh” before splitting the verses, and then all the content would combined into a .md file, which has only index inside.

The folder in the download is labelled Version 1. Is there a download to Version 2?

That is an interesting workaround. I wonder, does it break if you have overlapping ranges?

1 Like

Yes, for overlapping ranges, you can go up a header level for the encompassing range if one range was a subset of the other. It will break down at some point with lots of overlapping ranges.

For me, this will cover my general range cases and be good enough until someone develops something more robust.

I am sure someone is working on a plugin for the kit that will handle a string of verse references, much like verse searching in most Bible software.

All workarounds have trade-offs. Things don’t always have to be perfect to be helpful. Obsidian and the kit give us lots of options and flexibility.

4 Likes

Does anyone have advice on the best way to cross reference between verses? I could just cross reference to a heading like this [[Matt-27#v46]]. This works well because I can click and navigate directly to the verse but there are a couple of drawbacks.

  1. Notes have backlinks but I don’t think that blocks or headings do.
  2. I don’t think that headings show up in graph view at all. It would be nice to add that. Feature Request - Display headings and blocks in graph view

Use Case
In Matthew 27:46, Jesus is quoting Psalm 22:1. I’d like to have a link to both going in both directions.

Other Approaches
At Bible verses cross-referenced as wikilinks @cvr created an entire vault that already has each verse on a separate file and already cross referenced.

Having an issue linking from a note to a verse block when the chapter is long. For example in 1Corinthians, when linking, I can only scroll down to verse 49 when there are in fact 58 verses. Can anyone offer any help?

Screenshot 2021-06-22 at 10.12.20

It happens for me as well. Maybe it is a bug? I am on macOS.

Does it happen on all your notes? I find that I can only scroll down so far on all my notes, which if you want to link to a specific block of text in a note you cannot.

Same issu for me. I’ve been troubleshooting it for quite a while now. Tomorrow I’ll try to run this script from a mac to check if the issue still remains.

Yes! Any really long note in my vault, not just the Chapter files from the Bible Study kit, exhibits the same behavior. The scroll lists ends before reaching the end of the document when I use the ^ for block level linking.

Was succesful running Joschua’s script from a mac yesterday. The Obsidian vault was created in the translation I chose (NVI-PT).

I believe there’s something not working for windows in @jgclark ruby script (used in joschuas’). Maybe it’s another gem needed to be installed? I’m not sure and also not really well versed about running scripts.

Anyway, happy that it worked on a mac!

This kit is amazing! Thank you for the hard work.

When running Joschua’s script today on a Chromebook I had to install ruby then two gems (sudo gem install colorize, sudo gem install clipboard).

maybe a dumb question, but i’m not able to run the scripts - i get an error message that ‘cannot load file — colorize (LoadError)’