Why does Loading Workspace take so much time?

Hi,
I have around 40.000 files (not only .md, but also .pdf, .png, .xls, …) in my vault.
For some time now, after starting Obsidian, the “Loading Workspace” part of the startup process needs around 4 minutes to finish… Why is this?
Can it be, that it has something to do with a OneDrive-Synchronisation of files, that are modified by another Obsidian instance?

Here is my Debug info:
SYSTEM INFO:
Obsidian version: v1.5.12
Installer version: v1.5.11
Operating system: Windows 10 Pro 10.0.22631
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Base theme: dark
Community theme: Minimal v7.5.2
Snippets enabled: 3
Restricted mode: off
Plugins installed: 51
Plugins enabled: 29
1: Templater v2.3.1
2: Excalidraw v2.1.7
3: Hotkeys for templates v1.4.3
4: Hotkeys++ v0.2.7
5: Minimal Theme Settings v7.5.0
6: Strange New Worlds v2.1.2
7: Periodic Notes v0.0.17
8: Style Settings v1.0.8
9: Tag Wrangler v0.6.1
10: Underline v1.3.0
11: Quick Latex v2.6.5
12: Dataview v0.5.66
13: Vantage - Advanced search builder v1.4.2
14: MSG Handler v0.0.6
15: Emoji Toolbar v0.4.1
16: Excel to Markdown Table v0.4.0
17: Tasks v7.1.0
18: Recent Files v1.3.10
19: markdown export v1.0.20
20: Commander v0.5.1
21: Whisper v1.5.5
22: File Color v1.1.0
23: Media Extended v3.2.0
24: Neighbouring Files v1.0.6
25: Importer v1.6.1
26: File path to URI v1.4.1
27: Shell commands v0.22.0
28: PodNotes v2.11.1
29: Image to text OCR v1.0.2

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

I have a similar issue, which prompted me to move my vault out of Google Drive. Didn’t seem to make a big difference. The only time I notice an improvement was when I messed up my Obsidian settings, and basically started a fresh vault but with all my data already in it. Started up super fast the first few times, but eventually bogged down again. I would guess it’s related to indexing, but would love to hear from someone that knows more about how it runs under the hood.
For reference, I have ~36,000 files (~16GB), a mix of mostly .md, .pdf and .jpg.

The vault location could be a factor, but vaults in OneDrive tend to behave as long as everything is set to be local and stays that way — though my vault in OneDrive is nowhere near 40k files.

One quick and easy test you could do is turn ON Restricted mode and restart. If things seem better, turn Restricted mode OFF and disable all your community plugins. Restart. Enable one-at-a-time, with restarts/reloads in between turning one on, and you’ll see the general startup time slowing down. Maybe you can narrow it down to one or two plugins causing most of the hang-up.

Other troubleshooting steps are here:

It should not take that long.

I suggest you try first with restricted mode on and restart obsidian. Then also try to move your vault in regular folder (no icloud/onedrive) and see how it goes.

It it still takes 4 minutes, open a bug report.

Hi,
thanks all for your answers!!! :slight_smile:

I tried restricted mode: No difference

Actually, my vault is 100% local. It’s only, that some folders - which I share with others - are synchronised externally. Actually I mixed something up in my previous post. The sync happens not by OneDrive, but by FreeFileSync, which syncs some of my local files to a shared OneDrive. The reason is, that I don’t want have all of my vault in a cloud, only for sharing reasons I sync the shared folders to OneDrive.

Regarding OP’s bug report, I have had somewhere around 4 minutes usually.

Experienced similar things but also experienced on a completely new install with the Obsidian (Windows Roaming and similar Linux) config folder empty that the fresh vault was already some 3000 files into indexing when the workspace decided to show.

On a fresh install you have no plugins or third party theme active, of course.
Another important piece of info: I don’t use any sync (git doesn’t count) so my folders are not in any trouble-making folders on Linux or on Windows.

I shared some of my experiences here:

My conclusion was that if I install with 1.4.16, all is okay, and subsequent asar installs don’t cause issues.
Any other fresh installer after 1.5 will cause issues.
(I have 2 installs on Linux (debian package and appimage) which I was using alternately, sometimes wiping the Obsidian config completely as well.)

Please go in the bug report thread and if you can provide a performance recording.

Hi gino,
you posted some help-advise here:

Do you think that also could help with my slow loading workspace problem, I reported here?

These are unrelated. The workspace loading issue is different from the cache loading issue.
For me, the 1.4.16 installer works, then you can let the app update to the newest version that the 1.4.16 is compatible with. Meaning the leash will be rather short for this puppy.