iOS and iclould: Stuck on loading workspace

Steps to reproduce

Open Obsidian, app gets stuck on “loading workspace”

Did you follow the troubleshooting guide? Y

Cannot open app at all to use restricted mode

Expected result

App opens vault as normal

Actual result

On iOS, upon app launch, “loading workspace” screen persists indefinitely.

Environment

Obsidian will not launch at all so cannot post debug. Using iCloud sync vault on iOS 17.2.1


Additional information

Attempts to resolve:
Force close app, reopen → same result
Delete app, redownload, reopen, connect to sync vault → same result. On one of these attempts, the app showed an indexing message, got stuck, when I force quit and reopened, it was stuck on “loading workspace” again.

2 Likes

Do you have a device running macOS?

If so, with Obsidian quit on the phone, you could use the Finder in macOS to go to iCloud Drive/Obsidian/{VAULTNAME}/.obsidian/ (you may need to set the Finder to show hidden files and folders to see .obsidian).

In there, rename or move the .workspace-mobile.json file. Wait a bit for iCloud to sync to the phone. Try to open Obsidian.

If you were using the core Workspaces plugin on the phone, you may also have to move or rename the workspaces.json (with a s) as well.

If you are comfortable doing the above, I’d give that a try.

2 Likes

I don’t currently but will later this week and will attempt

You need to configure both apps to view Obsidian’s iCloud Drive folder, but you can get to the .obsidian/ folder on iOS/iPadOS using Taio or Textastic (the two I know of and have used before).

So this resolved itself on my ~7th attempt of deleting and installing the iOS app and opening the sync vault. No changes to any files and without access to my MBP. Not clear on what the resolution was, wondering if an updated build was pushed to the app store in the last day or so?

do you have access to insider builds?

AFAIK, no. Would this be via testflight or something?

Yes it is on testflight.

@WhiteNoise I have access to TestFlight build and have same issue. It’s repeats on last version in TF and version in AppStore. I think you may have some report in TF from my account.

Cleaning workspace-mobile.json helping for couple hours then bug repeats and you need to do the same steps to delete file.

Since the most recent update of the iOS app (v1.5.8), I’m having the same problem. Tried more than seven times now, testarted the phone, but it just wont loas beyond “Loading workspace” Sometimes it wont even go beyond “Loading vault”. I am suspecting a memory issue. This is on an iPhone 13 mini.

Edit: well, fwiw, this solved itself also for me. i just kept trying and boom, eventually it worked. How many tries? Not sure, maybe 10-15 times? But it may also have to do with how long you wait before you kill the app, because last time I tried, I put the phone down for a while and when I picked it up again, Obsidian had loaded. How long was the waiting time? Definitely more than a minute or two because that’s how long I waited the previous tries.

Unfortunately, it turns out that this only worked once. Next time I opened Obsidian, the problem was back.

The Obsidian app on my phone has become unusable and I’m wondering whether there is a way of downgrading to the previous version. It doesn’t seem to be possible, or is it?

I just found this topic. I am experiencing the same problem. Deleting the files doesn’t always solve it. Sometimes it shows up when I select to skip syncing configurations files on startup. Now it’s on the verge of being unusable:(

Sometimes I get past the loading workspace screen only to stuck on the “No file is open” view, with the app completely unresponsive. Occasionally I can open a note and it freezes immediately.

I would love to help you get this sorted out. Can I join the beta, send debugs logs, or crash reports somehow?

The current stable build is the same as the insider.

Does this problem happen if you run obsidian with no third party plugins after deleting workspace-mobile.json

I was having this problem and it was driving me nuts. I tried removing the vault from my phone and doing a restore. Instead I ended up deleting my ENTIRE vault from iCloud. When I finally got my vault restored (thankfully I’ve been paying for Backblaze for years) I removed workspace.json from my Vault and now I can use the iOS app again (and the Mac app is still working fine too).

Yes. I tried multiple times deleting workspace.json, workspace-mobile.json.

iCloud syncing all new files, I reboot app couple times and always get this screen:

When I delete app entirely it helps for may be a day, then you got the same problem.

For all the people who frequently ran into this issue, it seems that you all have in common iOS and using iCloud.

Which iOS version are you using?

Paste your debug info below, which can be accessed by Command Palette (Ctrl/Cmd-P on Desktop, Swipe down from the top on mobile) enter “Show debug info”, and click “Copy to clipboard”.

Desktop

macOS, 14.2.1 (23C71).

SYSTEM INFO:
	Obsidian version: v1.5.10
	Installer version: v1.4.16
	Operating system: Darwin Kernel Version 23.2.0: Wed Nov 15 21:53:18 PST 2023; root:xnu-10002.61.3~2/RELEASE_ARM64_T6000 23.2.0
	Login status: logged in
	Catalyst license: vip
	Insider build toggle: on
	Live preview: on
	Base theme: adapt to system
	Community theme: Atom v0.0.0
	Snippets enabled: 0
	Restricted mode: off
	Plugins installed: 8
	Plugins enabled: 6
		1: Dataview v0.5.64
		2: Excalidraw v2.0.23
		3: Git v2.23.2
		4: Jira Issue v1.56.0
		5: Natural Language Dates v0.6.2
		6: Tasks v6.0.0

RECOMMENDATIONS:
	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Mobile
iOS, 17.3.1

SYSTEM INFO:
 Operating system: ios 17.3.1 (Apple iPhone16,1)
 Obsidian version: 1.5.8 (126)
 API version: v1.5.8
 Login status: not logged in
 Live preview: on
 Base theme: adapt to system
 Community theme: Atom v0.0.0
 Snippets enabled: 0
 Restricted mode: off
 Plugins installed: 8
 Plugins enabled: 6
  1: Dataview v0.5.64
  2: Excalidraw v2.0.23
  3: Git v2.23.2
  4: Jira Issue v1.56.0
  5: Natural Language Dates v0.6.2
  6: Tasks v6.0.0

RECOMMENDATIONS:
 Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
 Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

I’ve found what seems to be a consistent work around to this. I believe the issue occurs when there is no local downloaded copy of the vault on the iOS device.

  1. Open the native Files app on iOS.
  2. Long press on your Obsidian vault folder and choose “Download Now”.
  3. Wait for the Obsidian vault folder to fully download to your device.
  4. Open Obsidian again and it won’t get stuck loading.

Unfortunately it seems there is no way on iOS to make sure the folder permanently remains local on the device, so you have to repeat the above download every day or so.

Does it freeze or does the progress bar still move?

The progress bar freezes with the “Loading workspace” step. The progress bar sometimes starts to animate again and then will freeze again a short time later.

1 Like