Loading workspace takes > 4min

Steps to reproduce

Starting Obsidian

Did you follow the troubleshooting guide? [Y/N]

Yes,
I started Obsidian in restricted mode with default theme and no snippets activated.

Expected result

That Obsidian would start within a few seconds.

Actual result

Loading Workspace lasted for around 5 minutes

Environment

SYSTEM INFO:
Obsidian version: v1.5.12
Installer version: v1.5.11
Operating system: Windows 10 Pro 10.0.22631
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Base theme: dark
Community theme: Minimal v7.5.2
Snippets enabled: 3
Restricted mode: off
Plugins installed: 51
Plugins enabled: 29
1: Templater v2.3.1
2: Excalidraw v2.1.7
3: Hotkeys for templates v1.4.3
4: Hotkeys++ v0.2.7
5: Minimal Theme Settings v7.5.0
6: Strange New Worlds v2.1.2
7: Periodic Notes v0.0.17
8: Style Settings v1.0.8
9: Tag Wrangler v0.6.1
10: Underline v1.3.0
11: Quick Latex v2.6.5
12: Dataview v0.5.66
13: Vantage - Advanced search builder v1.4.2
14: MSG Handler v0.0.6
15: Emoji Toolbar v0.4.1
16: Excel to Markdown Table v0.4.0
17: Tasks v7.1.0
18: Recent Files v1.3.10
19: markdown export v1.0.20
20: Commander v0.5.1
21: Whisper v1.5.5
22: File Color v1.1.0
23: Media Extended v3.2.0
24: Neighbouring Files v1.0.6
25: Importer v1.6.1
26: File path to URI v1.4.1
27: Shell commands v0.22.0
28: PodNotes v2.11.1
29: Image to text OCR v1.0.2

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I described the issue in this thread:

in short:

  • > 40.000 files (not only .md, but also .pdf, .png, .xls, …) in my vault.
  • my vault is 100% local, but some folders - which I share with others - are synchronised externally. The sync happens through FreeFileSync, which syncs some of my local files to a shared OneDrive folder. The reason is, that I don’t want to have all of my vault in a cloud, only for sharing reasons I sync the shared folders to OneDrive.
  • For some time now, after starting Obsidian, the “Loading Workspace” part of the startup process needs around 4 minutes to finish…

Can it be, that it has something to do with a OneDrive-Synchronisation of files, that are modified by another Obsidian instance?

1 Like

In which directory is your vault stored exactly?
Are you using ssd or hd?

If you disable/close freefilesync from monitoring your vault, does it start quickly?

Restricted mode on, default theme, close obsidian.
Open Obsidian and while it taking a long time to load the workspace,

Ctrl-shift-I/Cmd-opt-i → performance tab → record button → wait → stop recording → export to file → zip it and upload it here or DM to us on discord.

Hi,

  • the directory is: c:\pri\Obsidian\DeepThought\
  • I use a dell latitude 5400 with ssd

If you disable/close freefilesync from monitoring your vault, does it start quickly?

=> No

Here is the recorded profile:
Trace-20240513T204307.zip (186 Bytes)

You shared an empty file. Try again to do the recording.

Have you tried insider 1.6?

Hi,
yes, I have the insider 1.6 installed.

I waited 100sec until, then I clicked on “save profile”, see screenshot. This produces an empty .json-file… Isn’t that the step you expected?

Screenshot (see Error at the bottom, maybe that’s the reason, it didn’t work?)

The failure to save is an electron bug. We are gonna have to wait until they fix it.

Thanks for your answer! :slight_smile:
Could you please provide a little bit more information? At whom do you refer, when you write “they”? And why do you think did it start a few weeks ago and I didn’t had that problems before?
Thanks

I think there is some confusion. The long time to load the workspace problem, I don’t know why it happens. I still think that it’s something to do with your OS or there is some third party process that is interfering.

The failure to save a performance snapshot is an electron problem and the electron devs (they) ahve to fix that.

for the “long time to load the workspace” is that possibly related to this?

Tte original big report is from 1.5.12, so no.

Yes sorry, I found the issue with the author’s plugin, and forked a patch, seems to work