Where to find the original/default obsidian.css?

Hey Guys,

It’s amazing to see such a friendly community.

I’ve been building my own theme based out of other community themes. However I’d like to access the original/ default obsidian.css that comes with a new default vault.

I know that when installing a community theme the obsidian.css goes into the vault and by installing a new theme that new obsidian.css would override the previous one.

However, when I create a new vault, or delete a community theme obsidian.css from my vault, there is no default obsidian.css in the vault.

I couldn’t find the original obsidian.css in .obisidian either.

More than anything I’d like to see the original obsidian.css to make sure I’m structuring my css in the best way possible.

I must be missing something here, thank you for your time to read this. I really appreciate any help

Thank you!

PS: Apologies for saying obsidian.css so many times lol


If you disable the Custom CSS plugin, the obsidian.css file in the root of your vault should contain the default CSS.

Hey @insanum thanks, unfortunately it’s not working. I’m not sure what it could be, I’ll describe exactly what I did:

I have the latest obsidian version 0.8.14

I use obsidian in Manjaro Linux (with appimage) and I also tried the exact same thing on Mac.

I created a new vault. There’s no obsidian.css there yet

I go to settings > Plugin > Custom CSS > Turn on

This opens a new setting under:

Community Themes

I select a Community Theme (which generates an obsidan.css in my vault.

then I go back to Plugin > Custom CSS > Turn off

If I go to my vault directory the obsidian.css still shows the file from the community theme.

I’ve tried deleting the file to see if obsidian generates the default one and no luck, nothing happens if I refresh or close obsidian either

not sure what could be it. I appreciate your help!

So, are you able to see or edit or preview files?
If you can there must be a CSS.
I’m assuming it’s not hidden.
iirc, the Help vault always defaults to the default CSS every time it’s opened.

Hey, thanks for looknig into it, I’m able to edit all files correctly in the vault, community themes work, obsidian.css only shows once I set up a community theme, but other wise obsidian.css is not there when I create a new vault

Regarding the Help vault, that one doesn’t show obsidian.css either
I checked in linux in ~/.config/Obsidian/ and obsidian.css is not there either.

It’s really strange, since the help vault does have the default theme (black and purple text) but I can’t find the default obsidian.css anywhere

I can’t find obsidian css too. But I try to use community theme css, then delete it all the code. And I get original theme of obsidian.

so to edit (it start with blank css), I just add (copy and paste) some codes I find useful in here

If I want to change specific component, I use developer tools

here’s the result :

Hope this’s helpful :pray:


There is no original obsidian.css. The app’s core CSS is packaged and minified with the rest of the app’s front-end assets.

All of the suggestions above are good ones:

  • Use developer tools in the app to inspect existing styles
  • Download and review community themes
  • Check out posts here and on Discord

Thanks @sam.baron for clearing it up. I was trying all kind of different things to see the original .css, but that makes sense.

Thanks for the tips @jokysatria I’ll implement that way of building a personal theme.

Thank you guys for your time! That would solve it for me. I appreciate it!


Seems like I have tested a theme that somehow must have corrupted the generic background color scheme, since no matter what theme I try the background theme is grey. So, where in the ‘front-end assets’ do I find the original css. Also, deleting the ‘app’ and reinstalling doesn’t work, most likely because it’s an electron app.

Two things to check:

  1. Do you have a obsidian.css file in your vault? This would have been downloaded when you selected a community theme. You can delete this.
  2. Turn off Custom CSS in Settings -> Appearance

No combination of deleting ‘obsidian.css’ file seems to clear the gray background.


@Dor :clap::clap::clap::clap::clap::clap::clap: thank you. What a Community!

1 Like

On a Mac, use opt+command+I to open the developer menu, then click on sources, and select app.css

You’ll see the css settings for the default app; I think. See screenshot :point_down:


Reviving this thread. I’ve deleted some unwanted themes from the folder, and when setting my theme to “none”, I still have a lingering Traffic Lights theme. This persists when I toggle community theme, many appearance and editor settings, and restarting the app. Any ideas out there?

1 Like

Your screenshot shows “Apply custom CSS” switched on. There may still be an file “obsidian.css” somewhere between your note files in the root folder of your vault.
This is how CSS worked in Obsidian in the beginning before the vault/obsidian/… folder structure was introduced.

1 Like

Awesome, thank you! I got it sorted now!

Showing where the app.css file could be found was super helpful. Thank you!

Could someone please update steps to get obsidian.css? As the latest version 0.13.14 doesn’t have toggle custom CSS option. See screenshot below:

A few things to mention:
I had legacy mode endabled but then i disabled it to see if the toggle appears (unfortunately not…)

I also had Safe Mode turned off as i want 3rd party plugins and also turned this off as i wanted to have that toggle.

EDIT: Got it by entering developer menu (Windows: Ctrl + Shift + I), entering “Sources” tab → right click on app.css → Save As… → And just save it somewhere.

I was searching obsidian.css location and see this post, if you are like me trying to put a little piece of css code to override theme color, here is what I see and do:
see vault/.obsidian/snippets instruction? I create different css files and put them there, name can be anything you like, click refresh, then enable. Your customized style will be in effect.