Unable to undo text edits?

Hello, everyone!

I’m very new to Obsidian and while I adore it so far and have been setting it up, I’ve found a pretty significant issue and I’m unsure if it’s just my ignorance of how to navigate the program or if it’s a bug or if it’s a missing feature!

Basically, I can’t figure out for the life of me how to undo… anything. For example, deleting a line of text and then wanting to undo that action to bring that line of text back. I’ve tried looking in every menu I can click for an undo edit button and come up empty handed.

I’ve also tried ctrl+z and tried searching in hotkeys for an ‘undo’ type hotkey but I can’t find it nor can I find anything that ctrl+z is bound to. Is this something Obsidian just doesn’t support?

Any help is appreciated!

it is ctrl-z on win and cmd-z on mac.

I am on windows! I did just do another test with that ctrl+ z confirmation and I think I may have found the issue. I did get it to work, but I’m still confused why it’s been finicky earlier.

If I’m working between 2-3 different notes at a time does swapping between them affect my ability to undo edits?

Like, if I’m working in note A and then go into note B, but decide I’d rather undo what I’d last done in note A… In this scenario, would swapping to note B prevent me from undoing work done before the swap in note A?

Sorry if I’m being unclear or dense! Thank-you for the super quick response.

1 Like

If one the same pane you go from note A to note B, note A is saved and the history of changes in note A is gone.

1 Like

That would explain it! Thank-you so much for your help.

To solve for this:


I had the same issue, I solved it having a look to the external shortcuts.
I had shortcuts of other plug-in with the same sequence… control+z or control+x.
When I eliminated them from the shortcuts section of external plug-in, it worked again the undo… and redo… shortcuts…
Good luck!

Has this been addressed in updates since the last post? I stumble across the same issue on MacOS – when switching between tabs, redo stops functioning. I have the latest version of the app installed.