Undo not possible? no reaction to Ctrl-z, Ctrl-z not working

Things I have tried

What I’m trying to do

Sorry for be newbie question (just starting to use Obsidian, am immensly impressed):

Just accidentally selected my entire (long/important/unique) note with Strg-a, and with the stroke of one single key … all gone. Fortunately my sync setup saved me. But:

I see you guys taking about Strg-z/Ctrl-z here for using ‘undo’. But when I use that hotkey nothing gets undone, simply nothing is happening. Just double checked on a new note, reeboot etc.

Do I have to activate something to get Strg-z working? Any clue what I am doing wrong?

Thanks in advance guys! Am on Windows

Ok STRG is Control for german keyboards right?
You can’t undo if you have closed the document.
If you have 0.11.9+ you can try to recover using the file recover plugins

Settings>File Recovery>View> Search the file you want to recover

Thanks @WhiteNoise
File recovery plugin is marvelous. Yet too complicated to use routinely instead of simple undo.

Strg/Ctrl-z has no effect at all.

To replicate:

  • create new note
  • type two lines
  • delete part of last line with backspace
  • hit Ctrl-z (no matter left or right Ctrl)
    → nothing is happening

Will not rule out that the problem might be sitting in front of the screen. But cannot find any indication supporting that.

Yes, Strg is Ctrl on German keyboard. I am aware that there is no undo once file is closed. I file bug report?

Ok, this is getting really interesting:

Opening the help fault and trying Ctrl-z there-> it works!

So I went back into my own vault, disabled all core and community plugins, use ‘none’ as theme, checked I have not overwritten Ctrl-z in hotkeys:
→ still no reaction to Ctrl-z

Weird.

Must be some issue in .obsidian folder.

So the way I went now, in case someone else is stumbling across this:

  • create a new vault
  • manually copy all your files over into that new vault from your existing one. But NOT THE .obsidian FOLDER
  • manually recreate the environment you are used to with your plugins, your hotkeys, your theme, and your layout
  • manually rename your new vault (and possibly keep your old one as backup)

Now undo with Ctrl-z is working in the recreated vault.

Quite tedious enveavor. Though, probably less time consuming than trying to figure out what’s going on.

Hello. A bit late to the party. I ended up encountering this issue and was not willing to redo the whole setup as it was a nightmare. I used your solution and instead reset the hotkeys.json file in the .obsidian folder. (Please ensure that you have backed up your hotkeys file in case you may want to do the whole setup again as this will format all your hotkey customisations)

  • Create a new vault
  • Manually copy the hotkeys file in the new vault in the .obsidian folder it is named hotkeys.json
  • Paste this file into your vaults .obsidian folder. The environment you want the redo to work in. (You’ll get a confirmation prompt of whether you want to replace the existing file. Click yes)

When you go back to your environment all the hotkeys will have been reset and you can use the Ctrl-z to undo and Ctrl-y to redo. You’ll have to customise your hotkeys again but you’ll avoid having to recreate the entire environment from scratch.

1 Like