The obsidian on my iPhone won't start, it's stuck on the black screen (iClould Enabled)

The obsidian on my iPhone won’t start, it’s stuck on the black screen,I tried deleting the folder and reinstalling it, but it still doesn’t work.

Steps to reproduce

i can‘t run it,it just stun on black screen。

Expected result

Actual result



Additional information

I tried deleting the folder and reinstalling it, but it still doesn’t work.

Are you using iCloud?

I used to use iCloud, but then I deleted the obsidian folder on iCloud and reinstalled obsidian, but it still doesn’t work

I am having similar issues?

1 Like

Post a screen recording.

this is a link to show my screen recording

Dropbox - 视频 2024-03-08 01 58 11.mp4 - Simplify your life

screen recording

1 Like

I was having a similar issue on my iPhone, and for me it seemed to be a storage issue. Most of my phone storage (but not all) was used up. After I cleared up a bunch of storage space Obsidian has been opening for me again (not as fast as I like - but it opens consistently).

1 Like

this bug still exists in the new version. have you discussed it?
i hope it canbe repair,thanks

If you remove iCloud, remove obsidian from your phone and install obsidian again. Can you then open it and create a local vault on the phone?

i deleted iCloud and local obsidian folders before. and now the app can’t start, so obsidian vault can’t be created automatically.

i tried to new a folder name obsidian,even reset my iPhone, but it still doesn’t work.

could you provide me with the previous version?

i hope this bug can be repair next version,thanks

We are sorry but we are unable to reproduce your problem. I will keep the bug report open to see if somebody else can point us to what causes this for you.


I’m having the same problem. My setup is:

  • iPhone 13, iOS 17.4.1 (English language)
  • over 76 GB of free space on phone
  • using Obsidian Sync (plenty of free space there too)
  • no Obsidian files visible in Files app on “On My iPhone” or in “iCloud Drive” (checked on Mac too)

After starting Obsidian app - it does show Obsidian logo, then goes to full black and remains that way. Only iOS system icons are visible (time, localization services, carrier, wifi and battery).

This problem appeared after installing latest update from App Store. I have had 2 workspaces, with some plugins (nothing fancy) and separate config folder for mobile. My desktop version is working well.

Reinstalling app and restarting phone doesn’t change a thing for me.

I have no idea what to do next :slight_smile:

You should say “please” when you ask your users to troubleshoot for you, don’t you agree?

Honestly, the more I monitor this forum, the more I wonder if the Obsidian team holds their average user in contempt.

Thanks for the feedback, I’ll be more careful in the future.

@Codetheron Assuming you have a backup already, if you delete obsidian from the iphone, install it fresh. At that point, does obsidian open and can you create a new vault?

I am trying to understand if it’s a problem with obsidian or if something is messed up with your vault?

@WhiteNoise after deleting Obsidian from my phone (long press → Remove App → Delete App) and installing it fresh - it does start, shows Obsidian logo, then screen goes black and nothing happens from this point. I’m unable to do anything from this point - screen is always black (not including top bar system icons). After switching to other app / switching to home and going back to Obsidian - it’s still black screen. So it does not crash - it does not display anything. Pressing on random spots on screen has no effect too.

It’s interesting - I thought that removing App from iPhone will remove all it’s data. Maybe there is something in secure enclave or something.

Desktop (Windows) version works / syncs normally.

Do you happen to have lockdown mode enabled?
Even if you don’t use icloud, is icloud access enabled for obsidian?
Can you think of any change in the iphone settings that you made recently?

1 Like

Are you using a VPN? Where in the world are you?

@jfu do you still have this problem?

I have lockdown mode disabled.

But - indeed - in iCloud settings - there is iCloud enabled for Obsidian. After disabling it there - Obsidian does start and it does work with Obsidian Sync after configuring it!

Obviously - I was checking Obsidian settings before posting here, but there were only ‘Siri & Search’ and ‘Cellular Data’.

Thanks! :slight_smile:

well, I am glad we got closer to the root cause of the problem.
That should not be necessary.

If you now enable iclould where you disabled, does obsidian starts or the black screen returns?