The obsidian on my iPhone won't start, it's stuck on the black screen (iClould Enabled)

Indeed, after enabling iCloud for Obsidian - black screen returns.
After disabling it again - Obsidian runs normally, with sync enabled etc.

ok, now we have a hint where to look. Thanks

1 Like

Steps to reproduce

  • install obsidian on iphone (or ipad)
  • open the app
  • use it
  • delete the app
  • go on icloud and iphone storage and delete the obsidian folders (the application folder with the obsidian icon on it)
  • reinstall
  • open the app

Did you follow the troubleshooting guide? [Y/N]


Expected result

  • page asking to create my first vault

Actual result

  • Black screen


Ios 17.3

Additional information

Troubleshooting steps so far:

  • Go to iCloud , disable access for obsidian, open obsidian: page creation displayed, avle to create a local vault and to work with obsidian

  • Asked a friend who never installed obsidian: no problem

  • Asked the same friend to uninstall obsidian and delete remaini g folders (including the one with obsidian icon): problem reproduced - so my friend and I can’t use obsidian on mobile if iCloud enabled

  • No problem with Obsidian on MacOS, I reinstalled at the same time I wanted to move back all my productivity notes on obsidian

Have you tried restarting the device, and/or reinstalling the app again?

There’s also this troubleshooting post but it’s more for existing installations, not fresh ones. Blank / Black / White screen on startup / launch / open

Hello CawlinTeffid,

I have tried to restart the devices several times. No luck.
I read the post you mention, but it’s more for a MacOS installation than the mobile’s one.

I called Apple Support today and they told me this is an app issue (not in their perimeter). They discouraged me to logout from my icloud account (not recommended).

After deleting once again obsidian (installed to show them the problem) I updated my ipad and my iphone to iOS 17.5.1.

I reinstalled obsidian - same behavior :frowning:

I have 100+GO on my iCloud storage

This is super frustrating as I’m starting over Obsidian on my Mac and since I deinstalled the improvements are huge :slight_smile:

Hoping a solution can be found - I can’t share video of the steps to reproduce the issue or anything which could help to investigate further if needed by developers…

After you’ve reinstalled the app, does Obsidian have an application folder in iCloud again, or is it missing? (It probably doesn’t matter, I’m guessing in the dark).

Either way, if you a copy of the app folder you deleted, you might try putting it back from the Mac side to see if that helps (if there’s already an app folder, just copy the contents — including any hidden files — from the old one to the current one. (Again, I’m guessing here so don’t expect too much.)

Hi CawlinTeffid,

That’s the point: the missing application folder is NEVER created.
And … I don’t have a copy of this app folder because the original app deletion was month ago.

If someone can be so kind to check on their iCloud to “see” from a MacOS laptop where is the .obsidian folder and what is contained here, maybe I can copy / paste ?

The best would be the Obsidian installer to take in account a potential deletion (I understand the mechanism to avoid “erasing” an existing folder if any - what I don’t quite understand is how the installer is misled to believe there is already an app folder…)

That’s strange. Have you tried to manually create a new Obsidian folder in Files (or Finder)?

That folder contains vault settings. Configuration - Obsidian Help You could copy it from any new vault if you wanted to.

For sure, this is surprising behavior. It strikes me as likely to be an iOS issue rather than an Obsidian one, but I’m not a developer.

Another option would be to restore the whole phone from a backup that predates the folder deletion. Obviously that’s drastic and not something I’d personally be eager to do.

Hi CawlingTeffid,

Thanks for your input :slight_smile: let add more details :wink:

  • I created an obsidian folder in iCloud. This folder, created by a user does not have the icon of the app on it

-With folder created, I installed obsidian on mac iphone >> black screen

  • If I deactivate iCloud for obsidian on my mobile, obsidian propose to create a vault on my mobile

-at this moment, I have the obsidian folder created on my iphone with the app icon

My guess is that there is a missing hidden configuration file or folder to define this folder as the entry point.

To go further: I used obsidian on my mac, created a vault in my icloud “obsidian folder” :
the vault is created, the folder is not tagged with an obsidian icon, and still unable to start obsidian on my mobile with this configuration in place

1 Like

How strange and frustrating! Hopefully someone who knows more than I do will read this.

1 Like

Hi there, I’m running into this EXACT same issue. Followed the same steps as OP. I’m on iOS 17.4.1 and have re-installed Obsidian on my phone - I can only get the Obsidian app to open when I disable on “sync” in ICloud. I need it to open so I can change the vault location but can’t do it. Very frustrating and I hope the devs can reproduce this to fix!

Please, let me know if you still have this issue when you receive Obsidian Mobile 1.6.x


Hi all, I found this thread, and the last solution helped me. It seems that you need to log out of iCloud on your iphone/iPad for a while (I did 5 minutes) and then log in and no more blank/black screen

In AppStore, The current latest version is 1.5.12. How can i get 1.6.x? when will you release 1.6.x

It’s currently being tested in early access beta versions.

There’s no ETA for the public release.

1 Like

Thank you for your reply. This is a big bug problem. Will you repair it soon, and can realse the version as soon as possible.

Obsidian 1.6.3 is out. Do you still have this problem?

Solved for me … by me. I followed the advice to stop icloud synchronization on all my devices (iphone, ipad, mac) BUT only for iCloud drive.
At this moment, I was able to delete a strange folder named “Documents” with nothing in it (except .obsidian I got on another installation), and when I enable synchronization of iCloud drive again, it has been working!
After creating my first vault, obsidian asked me to update to latest version (so my guess it didn’t help).

I hope others will find a way to solve it :slight_smile: