Tags No Longer Show in Note in Preview Mode

I cannot find any setting to turn this on since the update. I used to be able to view the tags of a note in preview mode. This is no longer the case. In the meta data I use tags: with keywords set. And before when I used to preview the note I could not only see the tags but click on them Extremely useful and used it all the time. Now its gone. Am I missing something or is this a bug?

I am using MacOS. Have not tested in iPhone or Android.

The below would produce in preview mode a meta tag with the tags I could click on. IN the new UI it’s gone. I have no way of knowing which tags belong on a notes in preview mode.

1 Like

This is the link that explains with yaml.

It used to give the meta data.

Try enabling Settings > Editor > Show frontmatter, if that isn’t already enabled.

For bug reports it’s best to follow the bug report template. :wink:

One thing that stands out, tags in frontmatter don’t have a #, so your
- #TakingNotes/SmartNotes is wrong and won’t show up as a tag.

1 Like

It doesn’t matter if I have the # or remove the #. It doesn’t show. Before the update everything worked fine and it did show. Also when show formatter was on it only showed the tags and not all the other meta data. I only need to see the tags in preview mode. I wish I could roll back to show. Even if I shift back to legacy it doesnt work as it did.

Any ideas?

I tried different ways that it could possibly not show or break, but the only thing that consistently made it disappear was the #. If the “show frontmatter” is on, like holroy said above, and there’s no #, it should work.

Have you tried it on the sandbox vault/without any plugins enabled? If it works that way, it might be a plugin disturbing the functionality of this.

Before it used to say meta and only show the tags without the need for turning on the option. But now, if I do turn the option on it shows all the meta data and not just tags. I did disable all plugins also. I did have one that allowed the # in the meta called Frontmatter Tag Suggest. Even with all plugins off does not show the tags only. It’s either all the yaml meta or nothing. In this update something was changed. If I can rollback the software I could show a screen shot. The only way I can see tags without al the other meta data is put them in the body. But if I do that, in the dataview query the tags no longer show if in the body and not in the yaml tag section.

table file.cday as date, tags
From #Country/US/States/MT 
sort type, file.cday desc, tags

Now only shows the tags as -, empty.

When it was in the yaml definition, it would display the tag in the list as well.

File42 date tags
Rpt00018. Montana Rivers in Ruin, And No One Cares July 22, 2022 -

With the tags in the yaml section you get

File42 date tags
Snyder, Michael. 2021 — The Reason They Come to MT July 14, 2022

I didn’t solve the original issue yet, but I solved the dataview issue in case you need it. Use file.etags instead.

table file.cday as date, file.etags as tag
From ""
where contains(file.etags, "MT") and type = "LN"
sort file.name

thanks, had the same problem, though with “metadata” not showing in ‘read mode’, and this fixed it (don’t know how I turned off the show metadata in read mode in the first place).
By the way, in preview mode, the yaml tags do NOT appear as metadata, they continue to look like code:


  • sometag

Is that a difference between Windows and other op. systems?

I am not sure as I am on a mac. But on the mac if the tags are in the yaml section they do not show at all. If I turn on the option then I get all the meta data. I wish they would fix this. I will have to go over all my notes 1000 and move the tags out of the meta data and place them in the actual body. So annoyed.

TL;DR We can now either show all or nothing of the metadata, using the CSS snippet provided in the “Reduced frontmatter in reading view” we can however hide all other metadata (or to some extent choose what to show).

I don’t think it’s correct to call this a bug. It’s more of a work in progress, as they seem to be reworking the metadata part of Obsidian. In this post I’ll show some quotes to why it seems to be like this, and towards the end, I’m going to show a CSS snippet to help whilst they’re working on it.

References as to this ss a Work In Progress

From Obsidian Release v1.1:

Show frontmatter does now either show all or nothing of the metadata, and the actual frontmatter section is always hidden in reading mode.

Here @rigmarole states what I said earlier on that there is ongoing work with the metadata/yam/frontmatter section, so some changes will occur in the near future.

A temporary fix

In the post above, I post a CSS snippets which allows for the tags and aliases to be shown, and all else hidden when the Show frontmatter setting is turned on.

It also talks a little about the fact that currently we can choose to show/hide the tags line, the alias line and all of the rest of the metadata. I would love for us to be able to further style/handle the various bits and pieces of the metadata, so I’ve also written a feature request, which you could support if you agree that would be nice:

I have the same question. I think showing tags in preview mode is very useful.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.