PDF Export - Copied words are reversed, Searching in PDF only finds reversed words

Things I have tried

Used the sandbox vault (without plugins, themes, etc. installed) to export a note to PDF using the built-in PDF export functionality.
Viewing the exported PDF in the default PDF viewer on macOS (Preview app) works just fine. However copying words will reverse them and searching for words in the PDF will only find them when you search for the revered word.

Doing the same with other applications like Chrome or PDFexpert works fine.

Found another topic in the forum both in the bugs and help category which were both left unanswered.

Maybe it has something to do with fonts not installed? However I do think that exporting a PDF with default theme and no plugins installed should result in a proper PDF that should be searchable in any viewer.

What I’m trying to do

Making an exported PDF searchable / copyable.

I noticed my exported PDFs weren’t allowing me to search for a word that I knew was there and stumbled on this post.

I tried search in Preview as you suggested but even that only works when searching for the word backward. Almost every PDF app that I have only finds the words if I search for it spelled backwards. Highlights, PDF Search, Preview, DEVONthink, PDF Expert.

PDF Nitro works when searching normally.

Mac Preview actually shows me the results written backwards.

Tried turning all plugins off. Exported PDF and same results.

Looks like this is an Apple problem but they are going to change the font that Obsidian uses for print as a workaround.