Export to PDF - searchable only when word is typed backwards

Steps to reproduce

Export PDF.

Expected result

Expected to be able to search the PDF for a term that I knew was in it.

Actual result

Search only finds the word if the word is typed backwards.


Mac OS 12.3
  • Operating system:
  • Debug info:
    Obsidian version: v0.15.8
    Installer version: v0.15.8
    Operating system: Darwin Kernel Version 21.4.0: Mon Feb 21 20:36:53 PST 2022; root:xnu-8020.101.4~2/RELEASE_ARM64_T8101 21.4.0
    Login status: logged in
    Catalyst license: supporter
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: Prism
    Snippets enabled: 3
    Restricted mode: on

Additional information

Tried turning off plugins. Export PDF. Same result.

Almost every PDF app that I have only finds the words if I search for it spelled backwards. Highlights, PDF Search, Preview, DEVONthink, PDF Expert.

PDF Nitro works when searching normally.

Mac Preview actually shows me the results written backwards.

Here’s another person experiencing the same problem. PDF Export - Copied words are reversed, Searching in PDF only finds reversed words

Does it happen in the sandbox vault?

Yes. Using an export to PDF of the sandbox vault note “Plugins make Obsidian special for you”.

macOS 12.5 and Obsidian 0.15.8

The text layer in the PDF is clearly corrupted.

does it happen in any pdf reader?

If you use acrobat reader, does it work?
(This is not happening on windows.)

Do you have left to right set anywhere in your system?

After some googling we believe this probably a combination of Chromium, the font that gets embedded, and Apple. With most of the blame likely on Apple. We invite you to file a bug report to Apple.

For the time being, we are going to revert to old font “Inter” just for printing as a workaround for this issue (0.15.10).

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.