Obsidian starts with a blank screen

I have been using Obsidian without any issues for a while now. 14 days ago on Mar 8, 2022 (in Australia) Obsidian started with a blank screen (making it unusable). I was able to resolve this by reinstalling the application. It worked then for 7 days and then on Mar 15, 2022 it again started with a blank screen but this time reinstalling it does not work.
I am running it on a Windows 10 laptop.
I was able to get it to briefly run by deleting the Obsidian folder from my $Appdata locally and roaming and then reinstalling the app. It then ran for a few minutes but then failed, first losing connection to plugins and then after restart was back to a blank screen.
Attached is an error trace from the command prompt. My companies IS support checked for sync issues and said that for some reason the computer is switching to running offline.

The app doesn’t need to connect to the Internet to work whatsoever. It’s only doing that to see if there’s any updates available.

Hard to figure what’s happening, though. Can you post a screenshot of what this blank screen looks like?

Another option is to go into your vault folder using the system file explore and enable viewing hidden files. Then, create a backup of the .obsidian folder by copying it elsewhere. Then delete the .obsidian folder, open Obsidian, and create a “new” vault by selecting your previous vault folder.

Obsidian saves vault settings to each vault with that .obsidian folder. If something’s gone wrong with your configuration, deleting it will give you a fresh vault. Your files will stay there, of course, but you will need to reinstall plugins and re-set your preferences in Settings.

Thank you for your response. I should describe it as a blank (black) window. Obsidian does not load any vaults or their related plug ins. I can do nothing but close the application from the Windows task bar.
Attached is a screen shot of the blank window and the windows task manager.
I have tried your other suggestions but they didn’t work.
As I was using Obsidian without issues and then it stopped working makes me suspect that there was an update come through for Obsidian which now clashes with my Windows 10 set up.

Task Manager

When you launch Obsidian, try checking the console for errors:

To check for errors, first open the developer tools by pressing Ctrl-Shift-I on Windows/Linux or Cmd-Opt-I on macOS, and then go to the “Console” tab. If you want to save the error to a log file, you can right click on the error and choose “Save as…”.

Where is your vault stored?

On my C:\ drive

From your logs it looks like your vault is in a network drive

1 Like

Vault is definitely on local drive.

The console is blank.

You say your vault is on your C:/ drive, but it sounds like your company is involved somehow? Do they manage some kind of app sandbox/security/firewall, or mounted network user folders or something? Can you give more details about this?

1 Like

The only information I have on this is that it is running with a Cisco Anyconnect Secure Mobility Client with VPN and umbrella security.

Issue resolved - I turned off Chrome’s standard safe browsing security protection and found I was able to launch Obsidian. Once launched I have been able to reset the security setting in Chrome back to standard and Obsidian continues to launch and work as expected.
Thank you to all who offered assistance.


very odd.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.