Obsidian launches to blank screen on MacOS

Launching the Obsidian app on MacOS opens on a blank screen. Can’t open any vaults. Haven’t updated MacOS recently, on Big Sur 11.7.7.

Tried so far:

  • deleting app.json file in Obsidian Vault/.obsidian and restarting app.
  • renaming the .obsidian folder and restarting the app.
  • turning off safe browsing on Chrome (odd fix that worked for one user here Obsidian starts with a blank screen)

Any insights are appreciated. I’m new here, so please let me know if I need to provide more information before closing the thread.

Thanks in advance.

I’ve had a similar issue on Windows - deleting the obsidian…asar file in the app folder reverted the app to a previous version so it’s working but I’ve lost all the recent updates

Thanks for the reply, Keith. What do you mean when you say ‘lost all recent updates’? How was the app different?

Also, I can’t find the ‘asar’ files you are referring to. Could you give me a filepath please?

I have solved the issue for now. I simply updated the Obsidian app installation by installing afresh from the website, replacing the old application. The newly installed app opened my vault immediately, seemingly with all my formatting settings still intact.