Trouble with Obsidian on Chromebook

I’ve been using obsidian for a couple of weeks now, using a chromebook that has Linux Debian 12 running alongside ChromeOS. Earlier today I opened up my chromebook and didn’t need obsidian so I just closed it, but since then I can’t get it to open back up properly. Every time I try to launch it all I get is a blank gray window, making it impossible to do anything. It’s the same size as the usual start up window, and seemingly still has buttons in the same places that sort of work (i can press where the close window button would normally be and it closes the window, and if i click on the right spot on the window it brings up a smaller pop-up window, that is also completely blank and just a lighter gray)

I’ve tried uninstalling and reinstalling Obsidian as the regular Debian distribution (which i was using before), and then tried downloading it as an AppImage and launching it from the terminal, but it ends up the exact same. Likely worth noting that when i try and launch it as an AppImage, the terminal has a flood of text, with “Errors: link failed but did not provide an info log” showing up repeatedly.
The closest forum post i’ve found to my issue is this: Obsidian starts with a blank screen.
but none of the suggestions here seem to have made a difference.

Any help or suggestions would be greatly appreciated, thank you in advance.

There’s a post here where a member pinned it down to a bunk .md file.

I managed to do something similar once with a 2MB .md file full callouts and embeds repeating over and over. That vault was just a gray box when opening; no window buttons as all. Other vaults opened normally. Other apps froze as well when trying to open it - only BBEdit was able to open the file with without issues.

So one thing to try is, using the system file explorer (outside of Obsidian), look for any files that seem unusually large and move them out of the vault. It’s worth a shot.

This seems like the problem that i’m having, especially in the other forum post linked by that one: Obsidian goes black screen instantly after I launch the app

The only difference being that it opens with the blank window immediately, not giving a second or any time whatsoever of normal function.

I looked through all my .md files and the biggest one is 43KB, i tried moving it (and the second biggest at 39KB) to outside of the vault, but it doesn’t seem to have made any difference.

Yeah, maybe not the same issue then. It was worth a shot.

I’m not familiar with how ChromeOS is setup, what access you have to the file system, etc., but if you can try (any / all of these). Make copies/backup(s) first, of course.

  • Rename the {VAULTNAME}/.obsidian/ settings folder in the troublesome vault and see if you can start normally.
  • Rename the troublesome vault folder outside of Obsidian. When Obsidian restarts it won’t know what was loaded last, so should present you with the vault switcher / startup screen. Open folder as vault and select the new folder name to see what happens.
  • Create a new vault and see how things work in there.

Good luck!

i’ve now tried both of those, changing the .obsidian files names in terminal and changing the vault names in Chrome’s file manager. (couldn’t change the hidden files in Chrome’s manager so used the terminal) And am still getting the exact same result.

It looks like it’s trying to show the start-up window you were talking about, the window that pops up is the same size as that one would be, but completely blank gray.

Got it working again! Definitely in a less than ideal way, i ended up purging linux from my Chromebook, and then reinstalling it and setting up Obsidian again. At least all my notes are backed up to Dropbox so i can get them back.

Unfortunately i still don’t know what caused it, and this isn’t an amazing solution as it took almost an hour to do, but at least it worked.

A helpful person on Discord suggested deleting/renaming the .obsidian file. I did, and obsidian started and stayed open. That’s the good news.
The bad news is that all my accumulated themes and plugins are gone. A whole lot of customization is zapped.
This might be an issue worth addressing on the level, because I miss those customizations.
Thanks for your help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.