Obsidian shows blank window when launched

Steps to reproduce

Launch Obsidian. The main window appears but it’s totally blank. Worked fine until about a week ago. Nothing changed that I know of.

Did you follow the troubleshooting guide? [Y/N]

I can’t access any settings, etc. So not able to perform the troubleshooting steps.

Expected result

The Obsidian window to appear with typical content/menu items, etc.

Actual result

Just one window that is totally blank


Cmd-P doesn’t do anything so I can’t get debug info

Additional information

MacBook Pro, macOs Catalina, Obsidian v 1.5.3 (although I had the same issue with an earlier version of Obsidian)

I tried rebooting, updating Obsidian to the latest version.

There aren’t any error messages in the console.log

Do you happen to remember the last note you were working on before the screen went blank? If so, with Obsidian closed, you could try renaming that file in Windows File Explorer or the Finder.

If you are willing, another thing to try (with Obsidian closed) is moving or renaming the .obsidian/workspace.json file in the troublesome vault. This will reset the tabs you had open, sidebar position(s), ribbon order, etc., but may get you back to a working state.

Ok thanks, I’ll try those.

if it doesn’t work. Move your .obsidian folder out of your vault and go from theme. Some plugin might be causing this.

@ariehen @WhiteNoise I renamed the .obsidian folder then relaunched, and it worked! Thank you both!!

I’m facing the same issue. Could you explain what you did in detail?
In figure there is my vault.
I’ve already tried to rename .obsidian in xxx and re-lauch Obsidian, but I get just a black blank window

Hi all

have the same issue and also on iOS devices…cant move the .obsidian folders there right?