Obsidian stopped rendering on macOS

This bug is quite strange and its characteristics make it difficult to debug, or reproduce. The bug is that Obsidian windows will not render correctly - the window outline renders, but nothing else.

Steps to reproduce

I do not know what triggered this bug - I did not perform an update on the OS, OS drivers, or Obsidian itself. One day app was working fine, next day nothing would render.

Did you follow the troubleshooting guide? [Y/N]

No - because of the nature of this bug, I can not select menu items in the app such as " Settings > Appearance > Check for updates".

However, I have tried as much troubleshooting as I can - machine restarts, restarting the application, and I tried installing the newest version of Obsidian (1.5.3). The newer version of Obsidian exhibited nearly identical behavior to the older version I have.

Expected result

Expected the app to launch.

Actual result

Windows did not render.


It appears that I can not get debug info output (is there a command line version I could try?). My OS is MacOS 14.2.1

Additional information

I know that Obsidian does start - I can find its PID and it is consuming some memory and CPU.

Screenshot of the screen when I open the app is attached:

It seems the same, or related at least, to this:

I am not sure it’s exactly that.
If it happens when starting the app try this Obsidian shows blank window when launched

1 Like

Yes! That is the same issue I was having, and moving the .obsidian directory (or just deleting it) fixed the problem for both versions of Obsidian. I should not that renaming only the workspace.json file did not fix the issue, I needed to remove the entire directory.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.