Obsidian Publish with custom URL "too many redirects"

Hello,

I’m just started using Obsidian Publish with a custom URL. My publish URL is Obsidian Publish and the custom domain is https://ashour.dev

I followed the instructions in the help document, and using Cloudflare, I added a CNAME record to publish-main.obsidian.md and I have SSL set to full. I changed the DNS servers with my registrar and Cloudflare says it has full control over my domain.

I then went into the Obsidian Publish settings and set my custom URL to ashour.dev.

However, when I try to go to https://ashour.dev in any browser, I get the error message too many redirects or something similar. I have tried clearing my cache but it doesn’t work. I am on v0.10.9. Does anyone have any idea how to fix this?

what’s your cloudflare config? post a screenshot.
Also does redirecting www work instead of the naked domain?
Because you can’t add a cname to naked domain. So what are you doing exactly?


This is what I have at the moment, when I added the CNAME record I use @ for the name, I’m not sure if that’s the right thing to do, I don’t understand this stuff too well.

The exclamation point says “Another record shares the same name, so we’ve applied CNAME flattening”, which I also don’t understand.

EDIT: I deleted the CNAME and re-added it, then set my certificate to flexible then changed it back to full and now it works! Spent an hour trying to fix this, and it took all of 10 seconds to fix it. I have no idea what happened though.

3 Likes

I had the same problems and followed the steps on your EDIT, and it also worked for me! I did add “www” as a cname with a target of publish-main.obsidian.md. NOt sure if that’s necessary, but it’s what I did. (I don’t know much about this)

1 Like


I’m experiencing this issue as well. I’ve tried everything from this thread, does anyone have any other ideas?
Stuff I’ve tried:

  • Changed the SSL/TLS encryption mode to Flexible
  • Deleted the CNAME’s and re-added them
  • With www as a CNAME and without it
  • Multiple slightly tweaked configurations over the last few days