Obsidian often indexes the vault every time I start it; not just the first time (plus it asks to turn off Safe Mode)

This person here also asked this and got no replies:

And this one also didn’t really get solutions I think:

The same thing is still happening as of 0.14.15

It asks to turn off Safe Mode, and indexes the Vault.

Not a huge deal, but weird. Also it just takes a minute or so to index, so it’s a little annoying.

BTW, this happens whether I start the vault via a custom (Linux) shortcut on my desktop, or if I use the “Open another vault” button in the sidebar of Obsidian itself.

I’m using Linux Mint. And both the vault and the program are on the same drive (since that got asked in one of the threads linked above).

Any ideas?
Thanks!

1 Like

I had this issue once, and it was a particular file that wasn’t indexing properly, so it would try to reindex every time it started. I had a very large vault, and to troubleshoot I needed to add/remove folders or batches of files to narrow down which file(s) was not indexing properly. There may be an easier way to troubleshoot, a sync log that Obsidian keeps somewhere, but once you can identify the files it isn’t indexing properly and recreate them, you should be good to go.

3 Likes

OK, that’s an interesting point. But wouldn’t it re-index the vault EVERY time then? If there’s a problem-file, I mean? Because today, for example, it didn’t do that? Or actually I’m not sure about the indexing, but I’m sure it didn’t ask to turn off Safe Mode. So there’s some variability there that’ll likely make it harder to pinpoint.