Obsidian index loop for certain markdown files

Steps to reproduce

I generally use bash scripting for renaming, appending tags, modifying things at bulk. No issue faced. But today I have a folder which contains specific markdown files for mathematics. Which is causing issues.

issue → obsidian keeps on indexing everytime it loads and index about 1 item at a time and sometimes just struck at the count. So in theory if i have 2k files left to index, i have to restart obsidian 2k times, again in theory.

Link to the video → Gdrive

How do i know about that particular folder is causing issue?
I did inspected with all the steps suggested by Obsidian community and found out an issue on the obsidian forum. So followed the initials and got to know that this particular folder is causing obsidian to reindex everytime my SECOND BRAIN (which is my primary vault) loads.

With that in mind, I separated the math folder from my primary vault and created a debug vault. Primary vault is just fine and normal after removing these files but when we see the debug vault things tend to get interesting. The issue is replicated.

Desired result

I want to just get rid of this index popup every time i open obsidian.

Expected result

The vault should not struck in an index loop when massive md files are copied in the main vault from other sources.

Actual result

Index loop

Environment

  • Operating system: Arch Linux (i want to say it, i use arch btw)
  • Debug info: none

Additional information

  • I am attaching a video link for showing the same. Gdrive
  • Attaching the zip debug vault in which i am facing the issue.

Side note

First time using a support forum, suggestions are most welcome.

I don’t think there’s any loop. It’s possible obsidian never finishes indexing your vault because the parsers is stuck on some file(s).

Keep bisecting your vault until you find this file(s) and let us know what it is.

Thank you for your reply, I have a massive vault and all i can find was the folder that i shared, unfortunately its not possible to find that particular file inside the vault. In short the issue is related to ? MD files right?

edit → the folder was initially part of a larger vault, that folder is causing issues. I can’t really boil down to that single file alone due to time complexity.

suggestion
if obsidian can implement a faulty md finder or anything that would be great. Because its not humanly possible to go through that many files. luckily i spotted the problem early and can start disaster recovery, as i know what folder is the faulty one. Although it would take time but its possible. Now what if i don’t exactly know the problem, then it becomes an issue.

Query,
is there anything that can give me an idea of logs of index errors etc? does obsidian have a developer portal, or something else?

Yes, some or multiple markdown file are either malformed, way too big, or somehow tripping the parser.

Any way to automatically list parser errors.

It may not be an error. Bisect your vault to find the files.

I can confirm, there is some issue with indexing here. Or it could be just the case with me. but now my Second perfect vault which was fine a minute ago is on the same condition. reindex on every bootup

What happened here?

i moved folders while obsidian was still indexing, does that makes any exceptions being thrown? as the increment counter got freezed or i would say entire obsidian was freezed.

In short i am facing the same issue with a perfect vault, with which every markdown was made using obsidian itself, well not every but you get the point.

i would like to know about technical details so that i can get hang of the problem i have no idea what is going on, and no idea of debugging as well.

edit → i understand your indication towards faulty markdowns, but that is not the case with my second vault.

query → where is index data stored?

Create an empty vault and progressively move files there. Restart obsidian. See if the indexing gets stuck or not. If it doesn’t, add another batch of files. If it does, a problematic file is in that batch.

2 Likes

Thank you, will keep you updated.

update →

It just got fixed without doing anything.

I know nothing works that way but indexing was facing issues and now it works just fine. I haven’t removed any faulty files everything in my vault is still the same.