Note content disappearing on Mac OS Sonoma 14.0

Steps to reproduce

  • I open a note and leave it open
  • the content disappears
  • I press CMD + Z to revert

Did you follow the troubleshooting guide? [Y/N]

  • Yes. The issue did not occur in the sandbox vault.
  • I have tried uninstalling themes and plugins, to no avail.
  • This happens on all my computers that are synced.

Expected result

  • for my notes to not disappear

Actual result

  • my notes still disappear after an indeterminate amount of time.

Environment

SYSTEM INFO:
Obsidian version: v1.4.16
Installer version: v1.4.16
Operating system: Darwin Kernel Version 23.0.0: Fri Sep 15 14:41:34 PDT 2023; root:xnu-10002.1.13~1/RELEASE_ARM64_T8103 23.0.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: Things v2.1.19
Snippets enabled: 0
Restricted mode: off
Plugins installed: 6
Plugins enabled: 0

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.

Additional information

  • Including a link to a video showing me restoring the text. I cannot consistently reproduce the disappearance, though it happens eventually to every open note.
  • I did get a message from Obsidian itself once telling me that the note was being changed to sync up with changes made somewhere else. I don’t know how that could be though, since, even though I might have Obsidian open on both computers, and my iphone, and iPad at the same time (worst case scenario), I am almost never working on the same note on all devices at the same time.

Thank you!

1 Like

Please search before posting. Thanks.

Are you using iCloud to sync / is your vault in iCloud Drive?

Hi,

Thanks for yoru answer. I did search, but in all honesty I have no idea how I would have found the reference you pointed to in connection to my problem. I do appreciate you taking the time to help me!

I downloaded all of my files locally and I will see if this solves the issue! A tricky little problem…

All the best,
Joseph

I second this bug report.
I am using Obsidian Sync service.
I have been having this issue since the last update.

I have the same problem on MacOS Sonoma syncing with icloud. I tried to download the icloud folder to local but after some time the data seem to be only in the cloud anymore. I could not find any solution for this problem so far. In addition my bookmarks are gone and I get the failure message “Failed to load bookmarks. The data file is corrupted.”

@LNSY_sterius is your vault on iclould too? you need to make sure that your vault is off iclould and managed by obsidian sync only.

@madrera you need to make sure that icloud is configured to keep your files locally.

I was still experiencing the problem as of today but just unchecked the optimize storage option for iCloud and am hopeful that this will solve the issue.

I had times today where in the middle of a note it would switch styles because I assume it was reverting to a slightly older version of the file that was being synced from iCloud from another device. I don’t know … very confusing, but hopefully storing files locally will help!

+1 here for the same issue on macOS Sonoma 14.1.2 running Obsidian 1.4.16 on an Intel mac. I use iCloud sync and after reading this thread, I’ve also made sure that I’ve downloaded my Obsidian folder to local disk. @Jkhl1103 did this end up solving your problem? Fingers crossed this is the solve. I just started experiencing this issue today and the only thing I can think is that I recently ran out of hard drive space while using Photoshop. I’m wondering if iCloud automatically kicked a bunch of stuff to the cloud to free up disk space…

In case anyone else is having this issue and uses iCloud sync, I’ve been running Obsidian without this issue for a day now. Pulling the Obisdian sync folder to local disk seems to have been the fix.

This is no longer an issue. Can be closed. Thank you.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.