Not responding when Create vault -> Browse

What I’m trying to do

macOS 14.1, Obsidian 1.4.16
Initial Create vault gets mac pinwheel (Obsidian not responding in Force Quit dialog) when clicking Browse. After a few minutes the pinwheel stops but the Finder browse dialog never appeared.

Just trying to get started here. Default vault got created in Documents, but I was hoping to put it somewhere else. Is this a known thing?

Things I have tried

tried rebooting, restarting Obsidian several times. Though I can’t seem to get back to that “first time” create dialog - was going to look in the Console log.

A little more on this, also happens when clicking “Open” at “Open folder as vault” option. Then in Console immediately see:
18:20:02.677314-0500 spindump Obsidian [2004]: spin: not sampling due to conditions 0x400000000

So, something’s messed up. I’ve got a very vanilla set-up running on an otherwise functional Mac Mini. I do have some sync’ed drives, Dropbox, OneDrive, Google Drive, Box. Maybe that’s a problem.

I’m assuming other apps and the Finder work normally? Is there anything special you can think of about the setup of the macMini? e.g. restricted user account, network attached storage, etc.

When you have time, can you try creating a new admin user account in macOS and test opening Obsidian in there? If you can open it, save the vault to /Users/TESTUSER/{VAULTNAME} and create a few test notes and folders within Obsidian.

I’m wondering if the issue is isolated to your main user account or system wide.

Thank you for the helpful suggestion. I made a test admin account, and was able to browse to folder and create a new vault and a note (without the spindump pinwheel). So, I’ve got some maintenance/troubleshooting to do on my main (admin) account. Remove startup items, unmount/logout from drives, etc. If I learn anything interesting I’ll update the thread. If anyone reading this has seen hangs like this and knows a tip/workaround, I’m interested.

update, still having the issue, further steps taken:

  • Upgraded OS to 14.1.1
  • Disabled all “Allow in the Background” items in System Settings → General → Login Items
  • Disabled all “Open at Login” items in same (there was only one, Dropbox)
  • removed external drives.
  • Only apps running: Finder, Console, Obsidian
  • attempt to create vault: enter Vault name (“testvault”), for Location click Browse
  • Obsidian hangs with pinwheel (console not showing spindump this time, current excerpt below showing a sixty second timeout related to “Advance to configuration phase”)

default 10:20:32.502629-0500 Obsidian [0x7fea0cb4e070] activating connection: mach=false listener=false peer=false name=(anonymous)
default 10:20:32.503874-0500 Obsidian Advance to configuration phase.
default 10:20:32.503941-0500 Obsidian [0x7fea051aa140] activating connection: mach=false listener=false peer=false
default 10:20:32.504230-0500 Obsidian [0x7fea051aa140] invalidated after the last release of the connection object
default 10:20:32.504374-0500 Obsidian [0x7fea052e67f0] activating connection: mach=false listener=false peer=false name=(anonymous)
default 10:21:32.502772-0500 Obsidian *** Assertion failure in -[NSOpenPanel _initBridgeAndStuff], NSSavePanel.m:432
error 10:21:32.505449-0500 Obsidian Advance to configuration phase semaphore timed out.
0 CoreFoundation 0x00007ff8036f7fa6 __exceptionPreprocess + 242
1 libobjc.A.dylib 0x00007ff8031ed231 objc_exception_throw + 48
2 Foundation 0x00007ff8046e0106 -[NSCalendarDate initWithCoder:] + 0
3 AppKit 0x00007ff807a5dbe1 -[NSSavePanel _initBridgeAndStuff] + 1662
4 AppKit 0x00007ff807a5ebcc -[NSSavePanel initWithContentRect:styleMask:backing:defer:] + 257
5 AppKit 0x00007ff807a310ac -[NSOpenPanel initWithContentRect:styleMask:backing:defer:] + 133
6 AppKit 0x00007ff806f6dc03 -[NSPanel init] + 69
7 AppKit 0x00007ff807a5eaa8 -[NSSavePanel init] + 241
8 AppKit 0x00007ff807a5ca87 +[NSSavePanel _createPanel] + 47
9 Electron Framework 0x000000011ae246f4 _ZNK2v88internal11interpreter20BytecodeArrayBuilder5LocalEi + 262836
10 Electron Framework 0x000000011ac815cb ElectronInitializeICUandStartNode + 271819
11 Electron Framework 0x000000011ac82c37 ElectronInitializeICUandStartNode + 277559
12 Electron Framework 0x000000011ac82b10 ElectronInitializeICUandStartNode + 277264
13 Electron Framework 0x000000011bf3c18f _ZN2v88internal9Accessors12MakeAccessorEPNS0_7IsolateENS0_6HandleINS0_4NameEEEPFvNS_5LocalINS_4NameEEERKNS_20PropertyCallbackInfoINS_5ValueEEEEPFvS9_NS7_ISB_EERKNSA_INS_7BooleanEEEE + 10847
14 Electron Framework 0x000000011a962df6 Electron Framework + 826870

There is a general (old) issue on Macs with “” hanging with different apps. Booting in safe mode and then booting normally resolved the problem.

1 Like

Well, that was a rabbit hole. :sweat:

Thanks for letting us know was it was! I’m glad it’s sorted out.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.