New user, cannot install - "Obsidian is running" error

Hi, new user here, wanted to switch to Obsidian from Notion, but whenever I try to install Obsidian I get the following error: “Obsidian is running. Click OK to close it. If it doesn’t close, try closing it manually.”
If I click OK I later get another error saying that “Obsidian cannot be closed. Please close it manually and click Retry to continue.”
Searched online and found some similar issues but no solution applicable to me:

Anyone experiencing similar issues and can help?

1 Like

Can you give more information? What OS?

Do you notice any similar patterns from the questions and answers in that thread? After rebooting, do you see Obsidian processes still running?

Where did you download the file? What version is it?

This was the very first time you ever tried to install Obsidian? Did a first attempt fail or something?

Did you ever install any other apps that were called Obsidian?

Please give us whatever info you can to go on.

1 Like

Using Windows 10.
The errors are similar in the other threads, the difference is that they were upgrading from one version to another while my case it’s the first installation.
I see no Obsidian process running except for the installer. Have rebooted since and tried again, same issue happened.
Downloaded version 1.1.9 from the Obsidian website (https://obsidian.md/).
It was the very first attempt yes, I don’t think the first attempt had a different error, just the same one as I’ve already mentioned.
Don’t have any other apps called Obsidian, the closest thing I have is a theme for Notepad++ called obsidian and games from Obsidian Entertainment.

That’s strange. Sorry I don’t have many ideas.

Do you have any kind of anti-virus programs, or firewall apps that might be blocking processes? If you do, maybe they have a log where they would say that they blocked Obsidian.

Is the installer file on your local hard drive, or on a network drive, a cloud-synced drive (I think Downloads can be set to be synced in OneNote), or a USB drive? Anything you can think of?

The only anti-virus program I use is Windows Defender and tried disabling it and installing Obsidian to see if it would make any difference, it didn’t.
The installer file is in my local hard drive.

How does Obsidian check if it’s already running during installation? Is there something like a file it creates during installation?

I’m experiencing the same problem. No Solution so far. Disable Windows defender didn’t help.

System: Windows 10

Update:

  • I work through 1.0.0 installer, all the way up to 1.1.8 with electron 21. Hopping this is just a weird bug. Still got same error. So clearly something wrong with my computer settings.

  • I have Obsidian up and running in Ubuntu system. So I have a weird idea of install .deb through WSL2 (Ubuntu 22.04) as weird as it may sound, it worked