[Install] Cannot upgrade to new version "Obsidian cannot be closed"

Coming back to Obsidian after a few months, my last version was 0.13.23. A major upgrade required to download the new version manually, which I did.

I haven’t been able to upgrade, as I keep getting an “Obsidian cannot be closed” error, despite closing, completely uninstalling, rebooting, CCleaner, nothing has worked.

However, I’m still able to install from a 0.13.23 file I had.

I do not have Sync


It eventually updated automatically (not manually) to 1.0.2, now I’m getting this at every launch.

I’m still not able to install manually though, I read that it’s necessary


hmm strange. Can you describe your steps in “completely uninstalling”?

I used Windows uninstaller, also tried through CCleaner, and ultimately with IOBit Uninstaller which cleans any traces and leftovers left behind. I reinstalled through 0.13.23 everytime

why don’t you reinstall from the latest installer?!?!?

have you tried restarting you PC?

Which latest installer? I can look in the Discord which was the latest installer before the big upgrade. Don’t think it’s gonna change anything though xD And of course I rebooted, I mentioned it in OP

EDIT: Big upgrade seems to have been 0.14.5, but I can’t find an installer link to either this one or the one before. I don’t know why you think that would matter though. I can try to reinstall from my old 0.7.6 installer if you want xD

Why not 1.0 from the website?

Because it doesn’t work, that’s the whole purpose of my post


Have you tried restarting your computer?

I mentioned twice I rebooted ^^

I don’t know why this is happening to you. It may be something specific to your system.

On windows Obsidian is:

You can try to clean manually.

Both cleaned (IObit erases it all), still same error :confused:

Given that it’s hard even to imagine what might be going on, what happens when you try this?

And, maybe, what happens if you try to install portable (assuming you can find one)?

After going through those uninstalling steps, and rebooting - or not - do you find any Obsidian processes in your Task Manager?

I wonder whether there is actually some rogue process still running, or if it’s a glitch in the installer. I’m having trouble imagining how this could be happening. I wonder if there is somehow a hidden ghost duplicate installation somewhere on computer?

Or… is there anything else unique you can tell us about your setup? Did it just install to C:/ or did you install to some custom place, or network drive, or… anything else at all that you can think of that might be out of the ordinary?

Are you running any aggressive anti-virus/firewall software that might be causing side effects when installing? (Now I’m just making guesses up.)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.