Network error (tunnel connection) with 1.5.3

Hi, this my first post on this forum so it may lacks some precisions or i may have missed the answer to my question somewhere else (yet i found nothing close enough in the help pages or on the forum). Please let me now if something is missing or redundant (and sorry if that turns out to be)

I have been using Obsidian for a while and lately (just after the app auto-update to 1.5.3) i noticed the apparition of a ERR_TUNNEL_CONNECTION_FAILED error upon opening :
image
This pop-up may triggers multiple time (3~4) and can appear at random while using Obsidian (yet it does not seem to impact my usage of the app)

Since my organization use a VPN, i suspected that it was a related error. And indeed by turning off the VPN, no error upon opening.
The error does not trigger upon opening another vault (either the sandbox vault or a standard one), so it does not seem inherent to the vault but to the app itself (note that i don’t use any community plugin, only some core plugins)

Does the last update introduce access over the internet of some sort, which may fail under VPN ?
I noticed that the error trigger upon attempting to browse for community plugins so i suspect that Obsidian does not have any internet access when my VPN is on.
Can’t i just configure Obsidian to work offline, or do i have to set up in some way a proxy to allow it internet access now ?

Note that : i do not use Sync, Publish nor outgoing links display; my OS is Ubuntu 20.04.1; i do not have admin access; i use a snap to auto-update Obsidian (yet i got the same error with a downloaded AppImage)

3 Likes

I hesitated to submit this as a bug, yet since with a standard usage (no VPN) it does not happen, i considered that it might be an “expected” error when Obsidian is cut off from the internet

1 Like

I’m getting the same error, and I also work through a VPN. In my case, the error only started appearing after some IT updates to my computer (a mac), so I don’t think it is related to the release version. I tried rolling back to 1.4.16, and I’m still getting the error.

Found this previous thread re: proxies – Proxy setting

My takeaway so far is that I need to resolve this with my org.

1 Like

I have exactly the same problem, can somebody help ?

The problem started with Obsidian new update.

@sylvan i just tried launching the 1.4.10 (with the AppImage, still with VPN on) and i didn’t got the warning pop-up upon opening, could you check if it’s the same for you ?
I will try using this version for a while to see if the problem trigger again (i usually get it multiple times a day), maybe it is somewhat linked to a recent Obsidian release

I’ve been using 1.4.10 for two full days and didn’t got the problem at all. So it seems to be a regression. I’ll try to narrow down to which version it has been introduced and then open a new thread signaling the bug

Chalk me up as another with this problem, that has suddenly appeared.

I suspect that this is due to the fact that my corporate proxy requires a username/password and we are not allowed to add this to our system settings/keychain - we can only use applications that support supplying this info in their settings e.g. Postman, IntelliJ IDEA, or are capable of displaying an authentication popup like Chrome does for example.

I’m not sure why Obsidian have decided not to properly support proxy authentication (Proxy setting), seems rather short-sighted for a productivity tool, but sadly this might be the nail in the coffin for me if not fixed. I can live without Obsidian Sync (although I’d prefer not to have to, I don’t know why they don’t want my money), but I can’t deal with this popping up all day.

I’ve tested versions 1.4.10, 1.4.16 & 1.5.3 and the problem trigger only only on 1.5.3 so it seems to be a bug introduced in the latest version → i opened a thread about it in the bug section
here
I suggest to comment only in the new thread from now on