Nested canvas not showing content

Obsidian Release v1.1.5 (Insider build) - Announcements - Obsidian Forum

Embedded canvases now render a diagram of the underlying canvas. (1.1.5 release notes)

This is what I get in 1.1.5 with an ![[embedded.canvas]] in another canvas. Is this what is meant by “render a diagram”? The embedded canvas has an image, a markdown file, and a card on it.

Not saying anything is right or wrong with this view. Just looking for a reality check to set expectations.

1 Like

It’ll look a bit better in 1.1.6


Returning to this question now that 1.1 (public) is released. This is what I get when I embed a canvas into another canvas:

Am I wrong in expected to see the details from the embedded canvas, not just a collection of squares? The image is the default theme. In the Sandbox vault I get the same result. Embedding a canvas in notes – same result; blocks.

The official page describing canvases seems to imply we can see the canvas in a viewport.

Perhaps there’s some sort of css conflict, but since I get the same result in the Sandbox vault I wonder if that’s true.


It works for me in 1.1.6. What version are you testing this with?

I’m using 1.1.8 the public release, but it didn’t work for me in and of the insider releases.

I’ve completely uninstalled Obsidian, rebooted macOS, downloaded the public release, and created a new vault – the issue persists.

I’ve booted macOS (13.1) into Safe Mood and created a new vault there – the issue persists.

I’ve put Obsidian into restricted mode to disable all plugins, and rebooted Obsidian – the issue persists.

Oh I’m sorry. I said “it works for me”, but I wasn’t paying attention. I also can’t see any text in any of the embedded cards. It just shows a coloured outline of blocks, as a sort of preview.

Maybe that’s all that is expected to work at this point.

Thank you. Yes that’s what I’m trying to confirm.

The Canvas help at is probably the right answer.

CleanShot 2022-12-21 at 16.27.35

Great update, playing with it now! It seems that the bug also reproduces when you embed a canvas inside a note.

Correction: it is not a bug, developers are working on it.

1 Like

It’s not a bug though, just the current state of play. A deliberate decision.

1 Like

thanks for clearing that up!

I think this thread can be closed. We can wait to see how canvas nesting evolves.