Markdown Tables lines extend beyond readable length while working in edit mode. (Live Preview, Source Mode)

I’m curious if there’s way to not have tables extend far beyond the edge of my window (to-where I must horizontal scroll to see all of it, which I like to avoid where possible). For most elements while working in edit mode, lines wrap according to the “Readable Length” option I have set to on.

Screenshot showcasing this somewhat annoying problem:

I don’t mind if tables wrapping comes with caveats, as I already saw what they were like in Joplin; but preferably I would like the program to format wrapped tables in much the same way that wrapping list elements show up in edit mode.


I’ve poked around already in the interface, read through the help documentation, looked up plugins, searched this forum for my issue, etc. And I haven’t been able to find anything relating to my issue.

Thank you.

Settings > Editor > Line Wrap is on by default. Is it toggled off in your vault? Table cell contents wrap in Live Preview and Reading mode if you have that on.

1 Like

Thanks for the suggestion, but when I checked it was already set to on. I even toggled it off and back on just in case.

While viewing, both in read mode and live preview, tables look fine. It is only while editing a table, either in live preview or in source mode, that tables extend beyond the line wrap/readable line length limit. But any other markdown I see behaves according to the line wrap/readable line length limit even while editing.

Perhaps this is a bug? Editing tables seem to behave inconsistently from other markdown elements. Even code blocks adhere to line wrap–I checked.

That might be intended behavior, not sure though. Never noticed since I prefer the tables to not wrap when editing.

1 Like

it is indented behavior to not wrap table rows. Otherwise you are gonna have a hard time knowing in which row of the table you are.

In the future:

2 Likes

I see, I see also that your post has automatically been marked as Solved (which is what I want too). Thank you for the response!

It would be nice if there was an option to wrap source mode rendered tables though…I was already acquainted with wrapping tables in Joplin.

Tbh I just hate having to horizontally scroll LOL.

I’ll look into the Markdown Table Editor to see if it offers what I would like. I’m also “hearting” your Live Preview editor post. That looks like a great idea. Good stuff.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.