Linking an unlinked mention has destructive behavior (introduces spurious text as alias)

Steps to reproduce

  • Backlink to the active page by clicking “Link” in the Backlinks-Sidepanel
  • On some occasions it happens, sometimes it doesn’t

Expected result

  • It should just simply link the page name like normal

Actual result

  • Sometimes it moves the linking-portion a couple characters infront, creating a garbled character-mess
  • In this example, I am in the page called “CRP”, but when clicking on “Link” in the sidebar it didn’t place the backlink on the characters “CRP” in the other page, but instead a couple letters infront

image

Environment

  • Operating system: Windows 10
  • Obsidian version: v0.12.3

Additional information

This is a really annoying issue, as I regularly end up having to fix the garbled mess by hand. Any help is greatly appreciated!

1 Like

I am not sure I understand you problem. I can’t repro it.
Can you post some reproduceble steps with actual text that couses this?

It is inconsistent unfortunately. Sometimes it works just fine, then when I try the same linking again it acts like described.
I tried disabling all plugins, snippets and themes, removed my .obsidian folder and even reinstalled Obsidian alltogether. That did not fix it, unfortunately. Any ideas?

Trying to describe my steps a bit better:

  • I have a page called “Untersuchung”. Another page, let’s call it “Page B” has the word “Untersuchung” in it and I want to link back to the Untersuchung-Page from the backlinks-sidebar (by clicking on the link-button)

image

  • Expected behaviour: Orientierende [[Untersuchung]]
  • Actual behaviour: Orientierende[[Untersuchung|nde Untersuchung]]chung

This happens about every tenth time, I try this. I have a feeling, it happens more frequently, when I backlink a lot in a row.

Ok, I understand your problem. Unfortunately, I have tried some variations and I couldn’t repro.

If you find reproducible steps, especially something that can be reproduced in the help vault, please let me know.

1 Like

Just want to add that I have experienced this exact bug as well. I also tried to figure out a reliable way to reproduce it and failed to do so. Since I’m on a Mac and the OP is using Windows, it’s doubtful this is an OS/platform bug. I haven’t seen this one for a while but since I’m pretty focused on these data loss bugs these days and seem to be quite “lucky” to hit all of these edge cases, I will try again to repro it.

1 Like

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help. Once you’ve done the above, delete this line.

Steps to reproduce

I clicked to “link this file” under the outgoing link tab.

Expected result

I expected it to link the word in the present file to the proper link.

Actual result

The words were jumbled up and the link was created where the cursor was?

Environment

  • Operating system: Windows10
  • Obsidian version: 12.5

Additional information

post a screen recording

thank you.

If you are willing to share, could you DM me or @Licat on discord Matthew.md and Knox_Mathew_1.md so we can reproduce this problem?

Sure, it seems random though. If I “undo” and click it again it will be normal.

Sent.