How do you fix error: “ENOENT: no such file or directory, open”

Here is what is shown on my sync log:

2022-03-13 10:15 - Downloading file MPH/Year 1/Semester 1/Epidemiology/95�.md

2022-03-13 10:15 - ENOENT: no such file or directory, open ‘C:\Users\OneDrive\Documents\My vault\MPH\Year 1\Semester 1\Epidemiology\95�.md’ MPH/Year 1/Semester 1/Epidemiology/95�.md

I’ve searched the file directory both on Obsidian and on my local file explorer to find this 95� md file and not sure where it is.

If it doesn’t exist, I don’t understand what triggers Obsidian sync servers to continue to attempt to download this file.

Things I have tried

This post is based on a previous post: How do you fix error: “ENOENT: no such file or directory, open” - Resolved help - Obsidian Forum. However, the problem was moved over to resolved-help even though this wasn’t confirmed.

What I’m trying to do

I’ve search the file directory both on Obsidian and on my local file explorer

1 Like

Locate the directory MPH/Year 1/Semester 1/Epidemiology/ within your vault. Display a list of the contents of that directory. Spot any file that has a file name which starts with 95 followed by any other character which is neither an unaccented letter nor a digit, with a filename extension ‘.md’.

Rename this file in your vault by replacing the character which is neither a digit nor an letter by removing or replacing that character.

I’m having the same issue, did you manage to resolve it?

Not sure if this is the same issue.

It comes from the plugin dayplanner

Yep. I tried finding this mysterious “95 + character” markdown file in my epidemiology folder but had no luck. I’ve even moved everyone from my epidemiology folder to a copy folder and deleted the original folder. The error log still appears on my sync log for the time being.

For whatever reason, no matter how many times I delete this folder, Obsidian keeps syncing it back, even though now there aren’t any files within this folder. This is even despite me renaming the epidemiology folder to RENAME.
image

Interesting. I don’t have the day planner plugin but do have period planner.

I suspect this is more so because the person had trouble with their daily notes. Nonetheless, it still seems as though Obsidian refuses to delete my epidemiology folder.

So far no luck

I’ve deleted the epidemiology folder countless of times:

Only for Obsidian sync to continue to push the folder back:

Please let me know how I can get rid of this cursed folder?

Is this only happening to this folder?
If yes, just delete it in your file explorer instead.
Have you also tried to disable all your plugins to see if this error comes from a plugin?

I find no clear documentation about how Sync exactly works. From the little I could find I presume that Sync makes a copy of your vault on Obsidian’s Sync server. From what you wrote so far I come to the conclusion that the offending file with the unprintable name lies on Obsidian’s Sync server and not in one of your vaults. The unprintable name might be the reason why Sync can not copy to your vault because it’s not acceptable to the OS.

Which sync are you talking about?
This Obsidian Sync?

If yes, I can’t help you with that, you’ll need someone from the Obsidian Team

Good question. The file seems to have started on an onedrive folder, which presumably is also synced by onedrive.

1 Like

Just to update - still finding issues. Screenshot below:


It keeps re-uploading this folder no matter how I try to delete it (I’ve tried deleting it from file explorer AND onedrive folder yet still…)

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.