How do you fix error: "ENOENT: no such file or directory, open"

I created a new vault and tried making a note but got an error message saying “Failed to save file “202011091709”. ENOENT: no such file or directory open”

Not sure what I do to fix this

1 Like
  1. Well first of all, can you please include some basic details like what OS and Obsidian version you are using?

  2. Next, what other details can you provide? Is this your first ever vault? Or have you successfully used Obsidian before this new particular new vault?

  3. What path did you try to install to? (hide any private info in the path.)

  4. How did you create the vault? Did you go through the “Create new vault” dialog box? Did the directory already exist? Were there files already in the directory? Or did you do something like duplicating an existing vault?

  5. Does the directory you chose actually exist? Was it deleted or renamed? Do you have read/write permissions in the directory you chose?

  6. How did you try to make the note? Did you use the Zettlekasten or Daily Notes plugin? Or did you manually name the note 202011091709? If you used a plugin, is the plugin configured to use a specific directory. Does that directory exist?

I have only had experience with that when the path/file name reaches the maximum limit that the file can’t be created. It may have something to do with that.

Thanks Rigmarole.

  1. This is Obsidian v. 0.9.11 installed on Windows 10 pro

  2. I have other vaults and have been playing around with Obsidian and these vaults worked in the past. I moved folders to a new location and so that might have something to do with it. I have a folder called Concepts & Ideas Vault that has a .obsidian file in it and 2 MD documents that were created before the error. Not sure what program gets downloaded and where and how to make sure it points to the right folders.
    When I “switch vaults” I get an error for all the vaults except the help vault.

  3. I don’t recall the path Obsidian was installed to and am not sure how to look that up. Can you tell me what I should do?

  4. The initial valut was created when I doubleclicked the downloaded file. I think I created another vault by selecting a file folder for the vault.

  5. Not sure how to check what Obsidian believes the right directory is v. what microsoft expolorer shows as the file directory.

  6. I tried making a note by clicking “new note”. I also tried by clicking the zettlecasten note button.

I’m going to move this over to #resolved-help. If you’re still facing issues, could you open a #bug-reports?