Headers appear as one for internal links

Steps to reproduce

Use the following file.
0. Esercizi.md (34.3 KB)
Try to link one of the last headings in that file.
Try to link the “Esercizio 64” header and click it.

Expected result

I’d expect to be able to link every header in the doc.
When clicking, it should just select the relevant part of the header.

Actual result

When linking, it’ll let you select “Esercizio 64” but none after. If you write it manually it won’t be accepted (as if the header didn’t exists).

When clicking on the “Esercizio 64” link, the content of the following headers will be highlighted too, suggesting it’s considered as one.


  • Operating system:
    Windows 10
  • Debug info:
    Obsidian version: v1.1.9
    Installer version: v0.14.6
    Operating system: Windows 10 Home 10.0.19044
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 9
    Plugins enabled: 6
    1: Advanced Tables v0.17.3
    2: Excalidraw v1.7.19
    3: Outliner v3.0.0
    4: Novel word count v2.5.1
    5: Latex Suite v1.6.11
    6: Underline v1.2.1

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Works even in sandbox. Removing headers won’t make missing ones appear. Maybe it’s the length?

EDIT: Header “Esercizio 62” doesn’t appear as well and it seems it is under “Esercizio 61”. Header “Esercizio 63” works fine.

The version attached works fine in my vault and the sandbox, but only after sorting out the errors seen in the formatting when viewed in reading mode.

0. Esercizi.md (34.4 KB)

Original with errors

Modified version

EDIT: The installer you have is out of date:

The navigation and layout works in the modified file, but only you know if the content is right. Don’t trust anything I have done in terms of content. :melting_face:


This is psedo bug because the editor is using one parser and reader is using another. The reader is correct and you should not use the math block notation for inline math.

So the problem is that I would write

something here $$
My math equation

Instead of

something here
my equation


yes, it is.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.