Failed to load community plugins not resolved

I am facing “failed to load community plug-in” pop up in both my windows and in my iPad. I have tried to install and reinstalling it. Where as my android app is working fine.

I can’t access community plugins, change themes it is just stuck on that pop up. Although I can check the update for app but for plugins it shows me the same pop up.

Operating system:
Windows 10, iOS 15.7 on my iPad


Same problem here.

After the Recent Update (v1.0.3) I can’t:

  • “browser” community Plugins;
  • “check for Updates” for Community Plugins

What this issue is preventing me to do:
-Install new Community Plugins

Some other information based on other posts about the same problem

  • I don’t own a VPN

Operatin System:
Windows 10 Home, 21H2

1 Like

To both of you, what if you run and paste the results from “Show debug info” here?

Not just VPN, it could be some kind of firewall settings on your computer or router, or an anti-virus app blocking something. Just guessing…

I am facing the same issue as well, sharing the error screenshot in the link below:

Results from “Show debug info” below:

Obsidian version: v1.0.3
Installer version: v1.0.0
Operating system: Darwin Kernel Version 22.1.0: Sun Oct 9 20:14:30 PDT 2022; root:xnu-8792.41.9~2/RELEASE_ARM64_T8103 22.1.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Things
Snippets enabled: 0
Restricted mode: off
Plugins installed: 2
Plugins enabled: 2
1: Dataview v0.5.47
2: Calendar v1.5.10

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

1 Like

Hi @rigmarole , I’m facing the same issue on MacOs Ventura. Here are the debug details:

Obsidian version: v1.1.9
Installer version: v1.1.9
Operating system: Darwin Kernel Version 22.1.0: Sun Oct 9 20:15:09 PDT 2022; root:xnu-8792.41.9~2/RELEASE_ARM64_T6000 22.1.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 0
Plugins enabled: 0


The DNS solutions suggested in this thread (not just the single post) might work.

1 Like

Use case or problem

Ultimately the problem is living in China. Github (along with nearly every social media site, google, etc) is blocked here. Therefore I cannot load or browse community plugins without using VPN. I have a good vpn service but it only intermittently works here as the govt is constantly at war with these app companies. Why they block github is anyone’s guess.

Proposed solution

A big ask perhaps, but is it possible to mirror the plugins on the obsidian site itself (or somewhere else)? This would require an optional switch in settings, or an automatic switch if github is not accessible (for any reason including github being down)

Current workaround (optional)

I have no workaround aside from waiting for the vpn to connect (sometimes days, sometimes weeks if the security here is bumped up, for example during big govt meetings, or military exercises)

Thank you. I love using obsidian.

FYI for browsing you can try the online listing: Plugins - Obsidian

It’s possible to install plugins manually, but of course you need access to GitHub to download the files so that doesn’t help much. :face_with_diagonal_mouth:

Hi, thanks for the note.

I’m embarrassed to say it seems I was wrong about GitHub being blocked in China, I just visited there without vpn. Oops…

But the problem of “Failed to load community plugins” is still there if I hit browse in settings. I’m pretty sure that it always works with vpn on. Not sure what this means if the plugins are indeed being read from GitHub.

Can you access this site in your browser?

If no, it could be a dns issue.

1 Like

Hi Ariehen,

I cannot reach that link normally, “can’t find the server” or something similar.

With VPN :

I tried all morning to get vpn connected, now that I have I can verify that I can both reach that ‘raw’ link, and browse community plugins.

So I suppose that means a dns issue. Is that on the GitHub end or something to do with my ISP here? Sorry I’m not much of a systems guy.


Setting aside the VPN for the moment, if you can’t get to a site, it’s your ISP (or higher up). Changing your DNS may or many not resolve it. How to do it is linked in the thread or google “change my dns windows” or something similar.

I know it’s a pain, but maybe try a different VPN? I have a few friends in China who have no problems connecting. I’ll ask what they are using.

Can we move this to help? Thanks!

Moved to Help.

Thanks, let me dig into the DNS thing first.

I would be very surprised if someone could always connect to vpn no matter the service. The exception might be those run by Chinese companies. I don’t trust those for both the obvious reason of being in China, and the fact that vpn is technically against the law here so how does that work?

I have used ExpressVPN for years now and know many others who do. We all have a similar experience. I guess it’s possible my situation is worse for some reason.

So having said that I would love to know what your friends are using and I can give it a try. Why not.

Thanks again.

How’d the DNS switch go?

Confirmed what you said; ExpressVPN hasn’t been working reliably for a while now.
I wasn’t aware. :bowing_man:

Don’t know if it’s location dependent but a friend in Macau said PIA works most of the time for them. Another in Shenzhen said they (and many of their colleagues) use Astril. “Expensive, but solid” they said.

Good luck!

1 Like

Yeah those are the two big ones in China. I used Astril for many years until it went flakey then tried many others, ending up with ExpressVPN (also not cheap). If I were running the CCP Great Wall project I guess I would have the teams concentrate on the most used vpn services, so the trick is to find a good yet under-appreciated one. I often wonder what the top officials here use because hey, they don’t want to be locked out of YouTube!

As for DNS, haven’t done it yet. I briefly looked into it but I’m going to get some help with it first. (wow, forgot to hit reply on this the other day)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.