Editor: Add a toggle to disable automatic merging of changes (non-obsidian sync)


That card in the roadmap is related to improvements to Obsidian Sync. It has nothing to do with this FR.

Came here to +1 the frustration everyone else is feeling. It makes Obsidian pretty much unusable.

1 Like

Hi Stefanie,
Thank you for sharing this information.

I experienced the same issue with the auto-merge notification.
The issue has gone away since I disabled the ‘Day Planner’ plug-in.

As an alternative, I use ‘Big Calendar’ plug-in to summarise the tasks created in daily notes.

I hope others would find this post useful.


1 Like

I’m still seeing this problem a lot (posted first about it a year ago).
I’ve learned to live with it. When I type and words disappear I click CTRL+Z to undo and continue. When I see the …(1).md files in the file explorer and delete them. I make sure I don’t have any empty notes so when I do see an empty note I can use file recovery to fix it (happens rarely).
I got a new ipad and can now do a lot more work on that without issue. The new features are great.

I have some ideas about the merging issue:

  • it would be great if Obsidian can compare the two notes prior to merging. For example, when I add text at the end of a note on my desktop and a conflict is detected it should detect that the version from iCloud is contained within the version of the desktop (has a few words less). In that case don’t merge the notes, just ignore the conflict.
  • has anyone been able to kill the iCloud sync on windows and prevent an auto restart? If we had control over when iCloud syncs we could let it sync every 30 minutes or so and prevent a lot of conflicts.

I blocked iCloudDrive.exe in Windows Defender Firewall which will stop any kind of syncing. When you want to sync just change the rule from “block” to “allow” again and syncing will continue.

I’m testing this now to see if it’s a good workaround …


Lately I have been experiencing this issue on my Win 10 installation. Since I have used it less and resort to working on my iPad (non-iCloud install). I had learned to quit Obsidian when I was using batch search+replace with software like Notepad++ or Sublime Text.

My issue is not sync-related. I was thinking what could be causing this but because it happens on iPad as well, it is not an outside influence.

Hey guys. I am a rather new user to Obsidian and I’ve also run into the multiple file creation and the merging problems. I am using iCloud sync because I have a Win10 machine (work related) and several Apple products (Mac, iPad, iPhone) and I wanted to have my notes syncronized across all my devices. At first, I though that might be a problem for me but as I can see on this forum it’s quite a huge problem. Without going into details, because other persons in this thread already detailed the problems, I want to say that Obsidian is, in my opinion, one of the best note taking app but also has MAJOR problems regarding the auto-merge/auto-save options. I hope that the developers aknowledge this and implement the neccesary changes as soon as possible.

I’ve used the unison sync solution for 4 weeks now and am quite happy with it. It wouldn’t recommend it to a non-techie person due to the extra setup steps but it sure fixed my iCloud sync issues.
My Obsidian sync status has been green ever since


I am experiencing this troublesome issue, while I do NOT have any synchronisation or replication set-up. I am only using Obsidian on my Win10 laptop.

Has anyone experienced the same issue and found a solution or workaround?


Win 10 laptop here as well.
I usually have GitHub Desktop running but that doesn’t meddle with the files (does not save or edit them on its own).
First I was thinking it could be some indexing program (I run a proggy called Everything) but because this issue crops up on my iPad as well (less frequently though), it must be the latest Obsidian version… I don’t know. When you are writing Obsidian is indexing your current note and it might have something to do with retracting one’s words.
It would be worthwhile to check whether it is the Various Complements plugin doing it.

I usually try to be patient and press CNTRL+Z to undo and carry on writing.

No GitHub Desktop, not Everything, not Various Complements plugin

Maybe llinked to one of my plugins interferring – or a more serious flaw in Obsidian

Ctr+Z not always efficient indeed

A pain…

Is it not Auto-Save causing this issue???!

This issue happens far less infrequently since I made vault-wide changes to my YAML frontmatter format.
Actually, since using a frontmatter updater plugin, it is this plugin (or actually the background checks of Obsidian behind it) that seems to cause the message but no text is deleted like before. Thank Goodness.

I’m seeing this issue with Obsidian 1.4.2 on MacOS, syncing with iCloud. It happens frequently, like several times an hour while I’m writing. When the message appears the last few seconds of work are immediately undone. I don’t use YAML frontmatter at all. I never edit documents on two devices at once, so in my mind the ideal merge strategy would be “any changes made in this Obsidian instance in the last minute are golden and should never be altered by something coming in from the disk.”

EDIT: My only community plugins are Dictionary and Novel Word Count. I don’t think Dictionary alters notes, and NWC definitely doesn’t (I know because I made it).

There are several threads/posts where moderators don’t advise using iCloud, even on MacOS (let alone Windows), but there are some setting changes that need to be made (which won’t necessarily make the problems mentioned in this thread go away, alas).

I had the same problem. With the deactivation of the plugin “Update time on edit” the problem went away. I only use Obsidian sync.

1 Like

Interesting. And makes sense too.
I disabled that and installed a replacement mentioned above. Will try disabling that.