Merging changes automatically - content of document swapped/duplicated with another linked file's

I am not going to be well-liked with this one as I am going to open up a particularly nasty can of worms.

As I recently remarked, the old mainstay of automatic merging of changes issue seemed to be gone.
Not so.

Let me elaborate.

First things first.


I am not running Obsidian Sync.
I don’t use iCloud and my files are not in a folder used by Google Drive, OneDrive, etc…
I am using the latest publicly available version on all platforms.

The story

About 8 months ago, while I was making a How-To or Intro video on Obsidian for YouTube, I happened on a file of 180k size whose contents were swapped by a file that was a backlink of said file. I didn’t know what caused the swap or which app (I was using other apps than Obsidian at the time; not anymore). I resigned myself to restoring the file contents through my git backup.
In the meantime, I found one other similar case and solved it.

Today, it happened (almost) right in front of my eyes.
I was doing some janitor work getting rid of files with limited information. As I am wont to do, before I delete the file (in this case,, I delete the backlink in the other file ( (I wrote a line in the latter file that skipper must be a cognate with ship, where the h changes to k).
I deleted the file, but before I did, I received the usual message while writing in the other file: "" has been modified externally, merging changes automatically.
I didn’t pay attention to the message because I did not see any of my characters removed (like before).
A few minutes later, I went to the .trash folder to delete the files. Instantly, I saw my file had the information Size: 5 kbs.
Screenshot 2023-08-23 210234

I knew something was up because the file contained the YAML plus a single line containing a forwarding link to, so the size must be 1 kb.
I looked into the file with Sublime, and there it was, my complete contents of, minus the line I was putting in when … something happened.

So this is how contents are swapped/duplicated.
By the way, when I went back to, the last word of the sentence I was writing was missing. I did not see anything missing at the time the message was flashing up. A few moments later, it was missing. Utterly frustrating, that one.

Steps to Reproduce

Not easy, this one. You need (at least) two files which are linked with one another. Write into one file continuously and wait for the error message and keep checking the other one.
I have no idea what else is needed to reproduce what should not be happening.

  • Check the 2 or 3 threads on the subject that I don’t remember mentioning the swap/duplication.

At this point I have no idea how many files I could have that are potential duplicates (I could start investigating but I won’t). I checked for zero content files a few weeks ago and there were 1 or 2. I was happy about that.

One thing is for sure. This automatic merging business must be taken care of.
I don’t care much about the new core functions like properties or any bells and whistles…we need to feel secure that the time and effort invested is not lost.

Thank you.

1 Like

On the subject of duplication (duplicate content within one file) I already made some discoveries before.
I suspected the Taio app being responsible for it.

An exchange from 5-6 months ago:


Recently I’ve experienced the confounding case of duplications within heavier markdown files (250-320 kbs). Do you have any idea what might be causing this:
Almost the full text gets duplicated including the footnotes, so e.g. I have lines 1-1750 for original text and lines 1751-3400 or 3500 for an unwanted surplus (not exact duplications, only near exact).
I guess it has to do with large files and maybe wanting those files to be rendered as html. I’m not sure. Probably it is opening these larger files in preview triggers the issues.
Has anybody sent you feedback with similar problems or only me?

Taio dev Ying:

Sorry for the late reply, I will investigate this. I am not aware of such as case that can cause duplications.


I couldn’t reproduce just now but it’s either Taio, Obsidian, GitHub or git. Because of the nature of markdown files and their formatting and rendering, it must be either of the two, but because I hardly ever used Obsidian on mobile (my vault is too large) and my git commit history investigations led me to ascertain that the files grew twice as large after commits made on mobile, I can rule out Obsidian making the errors on desktop (I don’t own a Mac to have tried Taio on desktop).

Once in a while after git pulls I will try and reproduce with screen recorder on.
It happened twice with files size 325 kbs each (funny how two of my largest files should be exactly 325 kbs each).

If moderators think this has nothing to do with the topic raised or there are conflicts of interests, they are welcome to remove this second post.

Disabling plugins mentioned here and posts above it seems to stop these annoying messages from appearing and behavior happening.

The swapping of the content of one note in another note is pretty weird.

Did you figure out if/which plugin was causing this?

Lately was suspicious of it happening mentioned in this post.

Currently using frontmatter-modified-date ver. 1.2.1 (not the latest one). Error popup happens once in a while only now. Had a chat with plugin’s dev. See from here.