Dangerzone (FlowState-like plugin prototype)

That totally clarifies what you meant. I think it’s a great idea and have just added it to the latest release (https://github.com/akaalias/dangerzone-writing-plugin/releases/tag/0.0.10) - Let me know how it feels!

Feels just right! I really like it. Thanks!

1 Like

Hi, I like the idea, to add to my habit of 20 m writing a morning i want to get better at. When I start this though, the letter delete as soon as I get to 10-20 characters, not seconds. Do you have a list of what plugins or extensions to test turning off?

1 Like

My test to remove Text {{Expanded}} (saw above) does look like text stays on screen for number of seconds now, but it starts deleting from then, not if I stop typing for few seconds.
Maybe that is the idea and I missed the point though?

1 Like

Hi @tristanbailey – Thank you for asking. As long as you’re typing during a session, it shouldn’t delete anything nor should the text fade. Can you send a screenshot of your settings for dangerzone and/or a screencapture?

Yes, this is exactly what happened to me as well. Had a note open when the plugin was installed and I encountered the same error once it was installed. But opening a fresh note solved it and now the plugin works perfectly.

Love it and keep up the good work!

2 Likes

long time no see, pattman, good to see you are commenting on such an interesting plugin!

1 Like

My text gets deleted even if I keep writing. Am I the only one experiencing this bug?

2 Likes

No it happens to me too. Even if I set the writing time to 20 seconds, it just starts deleting even as I type.

Hi @Dangal and @jwb - Just to make sure: Have you tried starting by opening a new note similar to what @pattman mentions above?

@Dangal and @jwb – I was able to reproduce and “fix” the issue under the following circumstances:

  1. I have a note open
  2. I install/enable the plugin
  3. I start a session

Result: Text fades away and gets deleted even though I’m typing.

Problem: The note was open before the plugin was installed. Clicking the button doesn’t fully hook into the note/keystrokes aren’t registered to reset the timer correctly.

Solution 1: Refresh Obsidian (Command-R) to make sure plugin, note and keystrokes are hooked up
Solution 2: Close note and open again this one time to make sure plugin, note and keystrokes are hooked up

Both work for me. Let me know how it goes for you!

Thanks so much :slight_smile:

3 Likes

Thanks. That works for me! Great plugin, especially with the adjustable times. It’s good to be able to set longer times for harder writing jobs. :+1:

1 Like

I found there was a problem for me. When I was using non-English language to write something down, it always would delete all of the contents.

Author of The Most Dangerous Writing App here. Thanks for the plugin, helps me not having to use my own dirty code :wink:

I typically want to write with a word limit, not a time limit - useful for morning pages (500 words), or even doing the whole NaNoWriMo in one setting if you’re feeling particularly ambitions / suicidal (50,000 words). Could we get an options to choose from either time-limit or word-limit?

4 Likes

i installed your plugin.
i’m going in.

just here for moral support :sob:

2 Likes

Hi

I installed your plugin but it deletes everything I type even when I type continously. As I’m typing quickly, the text goes gray, then light gray, then dissapears, no matter how fast or often I type.

I’m on Linux.

Thanks

There’s the PaperCut plugin if you want a word limit.

I believe there’s a setting for how quickly text should be deleted—check there? Maybe it is 0 for some reason.

Hi! I have a suggestion. Could you make the plugin turn off not when you write a certain amount of time (1 minute, 10 minutes), but when you write a certain number of words or characters.
For example, you write 500 words without stopping and only after that the plugin turns off.
It would be cool if you implemented such a feature!

I can confirm that it’s not that.
I have it set to 5 secs and I have tried changing it, doesn’t help: once I start typing the text begins to fade out, no keypresses prevent that.