Can't paste images (or any attachment) into Obsidian editor

Things I have tried

When I copy an image and try pasting it into Obsidian editor with CTRL+V or Right Click → Paste, nothing happens.

The only thing that works is saving the images in the vault folder first, and then drag and dropping them from the Obsidian file explorer into the editor. But I can’t do this for the hundreds of images that I will be getting from screenshoting my professor’s slides.

I tried reloading the app many times, also reinstalling, disabling/removing plugins.

What I’m trying to do

I just wan’t to be able to CTRL+V copied images into my notes.

Please help, I am very close to just giving up on this app. THANK YOU!


If I open the help vault, copy and pasting images there WORKS FINE for some reason!

In which case the problem is most likely due to a plugin in the vault you were using.

Hello, I recently also observed that copy pasting only works if I create a vault in the desktop folder. Works with the same plugins, disabled or enabled.

What OS, and what version of Obsidian (including installer version)?

And since you said it works depending on where your vault is, maybe it is a file permissions issue in the original folder you tried to use. Maybe you have permission to write files, but Obsidian doesn’t.

Works fine for me with .jpg, .png, .jfif - on Win 10 PC laptop.

Might be formatting on the site you are copying from. Try other sites. Which format is the picture? How big is the picture? Could be something like that.

Try CTRL+SHIFT+V, to eliminate any formatting when you paste.

Both are v.0.12.19 (downloaded two days ago) on Win10 Home,

I also tried running it as admin (that should give Obsidian all the permissions or ?), but still doesn’t work.

Please believe me when I say this is not the problem, but thanks anyways!

1 Like

First step: disable any plugin, css snippets and use default theme.
Relaunch Obsidian and see if the issue persist.

Sorry, I couldn’t say. I really have no idea about permissions on Windows.

Another idea that popped in my head would be if you have any anti-virus or security style software that might be firewalling the app. If so, try temporarily disabling it.

I recently helped troubleshoot someone who switched ISPs. Nothing else changed, and then they couldn’t print except from their browser. And it was just some anti-virus firewall blocking certain services from running.

Also you can try to check the console in ViewToggle Developer ToolsConsole for errors. Maybe there is something else being blocked. Clues may be found there.

Thank you very much, it actually says this:


Thank you again, I am now trying to figure out how to get around hits

There we go! A clue!

Again I’m not familiar with Windows, but ~\Documents is a built-in Windows folder, and I never trust any built-in OS folder, or any folder that starts with “My”. You said Desktop worked. I wonder if any other custom folder would work. C:\Users\You\AnythingElse

In MacOS, apps have to be specifically granted access to files under ~/Downloads, ~/Desktop, or ~/Documents for example.

Windows has a similar security setting:
Settings → Privacy → Documents

In MacOS, you can choose which apps. In Windows, I’d be hesitant to grant all apps access. I’d personally just choose a folder outside of ~\Documents.

I had this setting on on the whole team, but when I tried to create a vault directly in C->Users–>myuser–>vault_folder, pasting images finally worked!

Thank you! You’re the only one (I asked many times on discord as well) who actually read what I wrote, everyone just said to disable/remove plugins even though I’ve said many times I already did that and that I was working with a clean installation. No wonder you’re a mod and an insider. Thanks again!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.