Can't Display PDF's

Things I have tried

I’ve created a folder inside the vault I’m using to store all my personal files. In this case it’s a PDF file. When I create a note I add a link by typing [[mylink]] to the PDF file. Good so far. When I click on the link the file is visible briefly then turns blank (grey) almost instantly. You can see the images in the thumbnails but not in the main viewer. What am I doing wrong?

What I’m trying to do

I’m trying to view a PDF file.

This has been fixed in the latest installer update.

Update your installer.
Just download a new version from the website, no need to uninstall the old one.
(Installer updates are sometimes necessary to update some dependencies and are noted in the changelog)

Thanks Joel, but that didn’t work for me. My installer version is 0.14.6. I’ve tried several files (there are 1000’s). Some did open, so I’m not sure if the problem is the file itself or Obsidian. All the files open outside of Obsidian. Many of the PDF’s were created with Nitro Pro so that might also play a role in this problem.