How to embed a pdf file?

I tried to embed some different pdf files with this syntax:





None of them work as expected. What I see, is this:

But I don’t see content. (Sometimes, I see a “flash” showing some content for a few milliseconds.)

These plugins I deactivated, without success:

  • Outliner
  • Obsidian Git
  • Mind Map
  • Kanban
  • Execute Code
  • Advances Tables

I use the standard Obsidian Theme, dark mode in Windows 10. But when I sync to my android smartphone (syncthing), I see the pdf-files in the android app …

Are there any other options to check under Win10?

Thanks for your help.

Have you downloaded the latest installer version ( 0.14.6 ) and re-installed Obsidian? There is no need to uninstall the application. This should fix your issue.

Thank you for the tipp, but it does not work for me. Same result. :smiling_face_with_tear:

I deleted everything that smells like Obsidian, also the vault with the .obsidian folder.
Then I installed Obsidian.0.14.6.exe again. Not themes, no extensions. Same result.

I tried Obsidian.0.14.6-arm64.exe, same result.

→ This seems to be a bug and I have found it.

What else can I try?

I tried simple pdf files.
aa.docx → aa.pdf works
bb.docx → bb.pdf works not.

→ One can only add simple(st) pdf files, or am I wrong?

Here are these files: (106.2 KB)

Are there (working) alternatives to embed pdf files?

I tried “Better PDF Plugin” 1.3.0, which shows the pdf content, but unsharp.

"url" : "bb.pdf",
"link" : true,
"page" : 1,
"scale" : 1.0,
"rotation" : 0,
"fit" : true

I tried Ozan’s Image in Editor Plugin 2.1.1, which shows no content (only preview)



I tried Annotator, which shows the pdf content, but unsharp.

annotation-target: bb.pdf

Additional text …

I don’t see how to edit the file, once it is saved, so I edit it with Notepad++.

A transclusion ![[Uwe2]] does only show “Additional text …”, not the pdf.

As of today there is no way to show a (more than trivial) pdf file inside a markdown file with Obsidian - am I right?

@WhiteNoise Looks like bug to me. Tried also embed a pdf file at new vault without plugins and got “can’t load pdf” message in embed frame.
I recreate pdf from he’s docxs files via print and couln’t embed them too. Nether aa, nor bb.